Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как переделать формат ячейки с числового на текст, так что бы впереди остался нуль?, изменение формата ячейки
 
Добрый день! у меня идут числа, артикулы, и в переди нуль. соответсвенно он исчезасает.
Я спарсил данные, и у меня формат артикуля Арт04715656, я убираю Арт, остаётся 4715656
а нужно 04715656. Нажимаю сменить формат ячейки, не помогает (( что то я не то делаю.
 
Код
=ТЕКСТ(ПОДСТАВИТЬ(A1;"Арт";"");"00000000")
Согласие есть продукт при полном непротивлении сторон.
 
igorasas, =СИМВОЛ(9)&ПОДСТАВИТЬ(A2;"Арт";"") или просто =ПОДСТАВИТЬ(A2;"Арт";"")
ну или вставлять в ячейки текстового формата и тут уже как угодно можно убирать "Арт" - хоть функцией, хоть через "Найти и Заменить"
Изменено: Jack Famous - 13 Июн 2018 18:33:54
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
Если надо изменить уже введеные артикулы, тогда так:
Выделяете нужный диапазон в одном столбце,
переходите в Основное меню -> Данные -> Текст по столбцам -> Потом выбираете метод деления -> Устанавливаете формат "текстовый".
в текущие данные эта операция не прибавит нужные нули, но позволит в текущие и нижние ячейки вводить нули как Текст.

так же можно превратить псевдодату(которая введена как текст) в настоящую дату, если выбрать соответствующий формат.(дата)
Изменено: Eco - 13 Июн 2018 23:31:54
Страницы: 1
Читают тему (гостей: 1)