Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
случайный выбор с условиями
 
Добрый день!

Коллеги, помогите решить задачку:
в приложенном файле в желтую область нужно собрать три случайных значения из каждой строки, при этом они не должны быть между собой повторяющиеся и не равны значению 1.

Сам попробовал поколхозить с индексом и случмежду,

UPD: В приложенном файле пример противоречивый - например в строке 18 всего два уникальных значения. Понимаю это, но это фрагмент большой таблицы где в строке из которой должна быть выемка данных будет как минимум 4 уникальных значения.
Изменено: Руслан Юсупов - 14 Июн 2018 13:00:49
чтоб дело мастера боялось, он знает много страшных слов.
 
посмотрите тему Случайные числа без повторов
это поможет избежать дублей при генерации случайных чисел
а с что с 1, то не скажу как вопрос решить
возможно дополнительную проверку прикрутить
 
Руслан Юсупов, не нужно писать через  1-2-3 строки.
 
По следам методов, предложенных Stics, попробовал сделать решение. Но как по мне получилось очень громоздко и все равно с ошибками и повторениями. В целом задача решена полуручными методами, но если поможете упростить и сделать формулу более лаконичной - буду очень благодарен.

Спасибо!
чтоб дело мастера боялось, он знает много страшных слов.
 
Цитата
Руслан Юсупов написал:
По следам методов
По тем же следам формула массива:
=ИНДЕКС(Лист2!$B$1:$B$8;ИНДЕКС(РАНГ($O2:$V2;$O2:$V2);;СТОЛБЕЦ(A2)))
Применил её к диапазону L2:N23. Вроде без повторов.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema,спасибо за вариант, но задача заключалась в том, чтобы не просто заполнить тремя случайными не повторяющимися значениями, но и чтобы они точно содержались в исходном массиве.

Т.е. в определенной строке (например 22) в 8 ячейках заполнены всего 2, это значит что в качестве конечного результата не может быть значение которое найдено случанйо но его не было изначально - в 22 строке это например Альфа-Банк или Банк ВТБ.
чтоб дело мастера боялось, он знает много страшных слов.
Страницы: 1
Читают тему (гостей: 1)
Наверх