Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Записать в Excel систему уравнений
 
Дано уравнение, которое нужно перенести в Эксель (прикрепил в файлы). Суть в том, что во второй линии уравнания только одно условие (на мой взгляд) и я не могу использовать логический оператор И; ИЛИ. Если их не использовать эксель начинает ругаться на кол-во аргументов (больше 3). Пока что формула выглядит следующим образом (не работает):
Код
=IF(OR(B4=B2;B1>B2);E1;IF(B4>B2);E2;E3)

В Е1, Е2, Е3 результаты уравнений

Использовать оператор я не могу, так как условия только ОДНО. Логично, что когда добавляю оператор и доп. условие (от фоноря конечно), то она начинает работать. Выглядит примерно так:

Код
=IF(OR(B4=B2;B1>B2);E1;IF(AND(B1=B2;B4>B2);E2;E3))
В формулу, что дали для перевода ее в эксель всматривался долго, но всеравно второго условия во второй строке не вижу
Если бы она работала, то в результате должна вывести результат одного из уравнений, которое будет отвечать условиям.
Ошибка где-то в написание второго условия, но где именно не знаю так как с экселем занимаюсь редко
В файлы прикрепил документ
Untitled.png (137.61 КБ)
 
используйте вложенные ЕСЛИ
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Что-то похожее должно получиться:
Код
=ЕСЛИ(И(x=b;a>b);formula1;ЕСЛИ(x>b;formula2;formula3))

где
формула1=
Код
=КОРЕНЬ(ABS(a*a-b*b))+EXP(2*b)

формула2=
Код
=(2*a*x*x+b*SIN(x))/(2+5*x)

формула3=
Код
=(3*a*a*x-b*x*x)/(a*a+x)

a, b, x - именованные диапазоны
С уважением,
Федор/Все_просто
 
Все_просто, премного благодарен)
Страницы: 1
Читают тему (гостей: 1)
Наверх