Страницы: 1
RSS
Поиск слова по нескольким ячейкам наполненных текстом с пробелами
 
Добрый день.

Можно ли автоматически найти слово (без учета регистра) по нескольким ячейкам наполненным текстом (с пробелами). Результат вернуть любом виде.

Спасибо за ответы. Николай.
 
Добрый и Вам. Попробуйте применить ПОИСКПОЗ()
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
если в ячейке не одно слово, присутствуют другие символы - не получается
 
pnv, от Вас небольшой файл-пример. В нём искомое слово и несколько ячеек, где это слово (словосочетание) присутствует. А также желательно поменять вот это:
Цитата
pnv написал:
Результат вернуть любом виде
Покажите, где и в каком виде нужен результат.
 
1. Прилагаю, слова "тест" или "файл" найти не могу - в этом проблема.
2. Результат должен сообщать присутствует или нет искомое слово.
 
Пробуйте
=СУММПРОИЗВ(--(ЕЧИСЛО(ПОИСК(F3;$A$1:$A$16))))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
См. вариант.
 
Юрий М, слово "файл" не находит, а должно
 
Не должно: см. Ваш файл-пример. Сделано в строгом соответствии с примером. А если бы в примере показали номер строки, то я написал бы макрос немного иначе.
 
Я был бы очень признателен, если бы Вы исправили макрос. Хотя я не понял про номер строки.
 
Цитата
pnv написал:
я не понял про номер строки
В Вашем же примере: номер строки выводится в ячейки столбца G. Что тут непонятного?
Цитата
pnv написал:
Я был бы очень признателен...
А я был бы тоже признателен Вам, если бы Вы ознакомились с Правилами. В частности, с пунктом 2.3. В той его части, где говорится о желаемом результате. Как только ознакомитесь - напишите. А я потом исправлю макрос.
Всё это я написал для того, чтобы Вы ценили время тех, кто пытается помочь Вам сэкономить ВАШЕ время.
 
Цитата
pnv написал:
Результат должен сообщать присутствует или нет искомое слово.
Нужно что бы формула вернула Присутствует или Не присутствует?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Доброе время суток.
Версия на Power Query.
P. S. Николай, pnv, случайно не из Екатеринбурга?
 
Цитата
Андрей VG написал:
Power Query
Спасибо, но существующий офис не поддерживает Power Query.
Не из Екатеринбурга.
 
Второй вариант.
 
Цитата
Юрий М написал:
ознакомились с Правилами
Ознакомился (было полезно в т.ч. п. 2.4. про персональные данные). Спасибо.
 
всем спасибо
 
Подошёл второй?
 
да все работает
Страницы: 1
Наверх