Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Счет не пустых значений за определенный период
 
Здравствуйте! Подскажите пжт как дополнить формулу ЧСТРОК(B1:B63)-СЧЁТЕСЛИ(B1:B63;"") чтобы она подсчитывала количество не пустых ячеек за определенный период который прописан в столбцах I и J. Пример во вложении.
 
никак
используйте =СЧЕТЗ(I:J)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Другую формулу не принимаете? Жаль. Другим пригодится :)
=СЧЁТЕСЛИ($B$1:ИНДЕКС(B:B;ПОИСКПОЗ(J9;$A$1:$A$63));"ааа")-СУММ($L$8:L8)
 
vikttur,  :oops: да считает,спасибо можно и другую, но ааа это разные названия они меняются, может еще есть способ подсчета не пустых ячеек
Изменено: Анжелика - 11 Июл 2018 19:34:44
 
туплю или не туплю ?
=COUNTIFS(B:B;"<>";A:A;">="&I9;A:A;"<="&J9)
=COUNTIFS(B:B;"*";A:A;">="&I9;A:A;"<="&J9)
Изменено: БМВ - 11 Июл 2018 19:39:48
 
Цитата
Анжелика написал: но ааа это разные названия они меняются
"ааа"  "?*"

Михаил показал лучше вариант:
=СЧЁТЕСЛИМН(B:B;"?*";A:A;">="&I9;A:A;"<="&J9)
 
vikttur, аaа это названия фирм которые берут в аренду на несколько месяцев товар,
в примере еще добавила пару якобы названий.
 
Виктор, опять приписками занимаемся? :-) "?"  вроде и не нужен.
Изменено: БМВ - 11 Июл 2018 20:16:27
 
Михаил, это не приписка, а железная необходимость - в ячейках  полно строк нулевой длины

Анжелика, зачем пример? Меняйте в формуле буквы на "вопросзвездочка"
 
vikttur, БМВ,
Цитата
Михаил показал лучше вариант:
=СЧЁТЕСЛИМН(B:B;"?*";A:A;">="&I9;A:A;"<="&J9)
Супер Класссно ВЫ КРУТЫЕ!!! Спасибо!
 
vikttur, а "вопросзвездочка" что означает подскажите пжт
 
Присмотритесь к формуле, которая Вам понравилась. Там есть то, о чем спрашиваете.
 
Цитата
vikttur написал: в ячейках  полно строк нулевой длины
Виктор, да, все ж туплю. не посмотрел на содержимое.
Страницы: 1
Читают тему (гостей: 1)