Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
почему не работает ВПР?, Не могу понять, почему не работает ВПР?
 
сабж
 
Сергей Ким, Откройте встроенную справку и посмотрите примеры использования, сразу поймете что не так.
 
Сергей Ким,Потому что вы не читали справку по функции
 
Сергей, в направлении "левый впр" идите  :)
в столбце J формула
Код
=ИНДЕКС(Лист2!$A$2:$A$13;ПОИСКПОЗ(ЭРДБ!G10;Лист2!$B$2:$B$13;0))
 
kalmar, вопрос был почему не работает, и ответ очевиден, другое дело, как сделать чтоб работало, и если №4 очевиден, то есть и загадочный вариант :-)
=VLOOKUP($D5;IF({1\0};Лист2!$B$1:$B$13;Лист2!$A$1:$A$13);2;)
или как это по-ру́сски
=ВПР($D5;ЕСЛИ({1:0};Лист2!$B$1:$B$13;Лист2!$A$1:$A$13);2;)
Изменено: БМВ - 9 Авг 2018 10:06:25
 
БМВ, второй день попадаю под раздачу от Вас :)
но ведь указал направление "левый впр" (ответил на вопрос "почему не работает?")
ну и дал вроде решение
 
kalmar, это из оперы научить правильно задавать вопрос. спросили почему не работает получили ответ почему не работает и не более. Про дать решение ни слова не было. :)
 
kalmar, да и раздачи не было.  :-) просто первые два ответа отсылают к азам использования, которые многие игнорируют, даже не смотрят в справку, про поиск я даже заикнутся боюсь.
Изменено: БМВ - 9 Авг 2018 10:09:42
 
Спасибо все принявшим участие в обсуждении. Глаз замылился, исправил
еще вопрос как найти I25.8, если в справочнике только I25.
по умолчанию, в условиях считается, что если указан  I25, то туда входят и все дочерние подпункты

Достаточно ли будет только поменять четвертый аргумент на Истина?
спрашиваю, т.к. не знаю, как работает алгоритм функции при Истина (
Изменено: Сергей Ким - 9 Авг 2018 10:58:31
 
Попробуйте искать I25* В вашем примере, если правильно понял, будет так
Код
=ВПР(ЛЕВБ($B2;3)&"*";Лист2!$A$1:$B$13;2;ЛОЖЬ)
=ВПР(ЛЕВБ($B2;3)&"*";Лист2!$A$1:$B$13;2;0)
=ВПР(ЛЕВБ($B2;3)&"*";Лист2!$A$1:$B$13;2;)

Формула одна и та же, только с виду разная.

Изменено: gling - 9 Авг 2018 11:27:54
 
а что мешает объединить в одной формуле
 
в формуле в колонке 5 (Е) искать в таблице на втором листе нужно не с первой строки, а со второй:
=ВПР(RC2;Лист2!R2C1:R13C2;2;ИСТИНА)
(или для Е2)
=ВПР($B2;Лист2!$A$2:$B$13;2;ИСТИНА)
Изменено: Ігор Гончаренко - 9 Авг 2018 11:27:39
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
всем спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх