Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как сравнить две таблицы и совместить данные при совпадении.
 
Добрый день!
Подскажите пожалуйста, есть таблица с обобщенными названиями Аптек, и есть вторая таблица где Названия аптек не все, но есть количества, нужна какая то формула. Которая бы сравнивала массив данных и при совпадении с массивом ставила бы данные из количества. А при их отсутствии ставила бы 0 Функция ВПР почему то не работает. Пишет ошибку #Ссылка
Код
=ВПР(B2;A2:A43;3;0)
 
Добрый и Вам. А если так:
=ЕСЛИОШИБКА(ВПР(B2;$A$2:$C$43;3;0);0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Это работает, но немного не так как бы хотелось. Хотелось бы чтобы он показывал так. Если в первом столбце Аптека у черта на куличках а во Втором столбце этого нет. то в значениях 0 или Н\Д
 
А если есть, что формула должна вывести?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Вернуть значение из столбца 3 напротив кторого стоит значение. извините если как то не так оъяснил
Название ПрепаратСерия №1Если совпадает  А и В то значение из С если нет то 0
Аптека у рака на гореАптека у рака на горе11
Аптека в 3 соснахАптека в 3 соснах22
Аптека у черта на куличкахАптека № 110
Аптека ГазАптека № 1030
ДОНАптека № 1220
ФармАптека № 1320
Аптека № 1Аптека № 1521
Аптека № 10Аптека № 1723
Изменено: kotlew - 10 Авг 2018 13:46:43
 
Так что ли?
=(B2=A2)*C2
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Надеюсь что не придется мне заполнять вручную таблицу.
 
=ЕСЛИОШИБКА(ВПР(A2;$B$2:$C$45;2;0);0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Огромное спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх