Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Обработка и подсчет значений из ячеек только с формулами
 
Добрый день.

В одной строке нужно подсчитать значения из ячеек, содержащих только формулы. Например в столбце А, строке 1 есть начальное число 1000. В последующих столбцах в той же строке есть вперемежку числа введенные вручную и данные полученные формулой (сложение/вычитание и т.д). В конце, в столбце АВ нужно суммировать данные от ячеек только с формулами.
Как это реализовать?
 
Цитата
memo написал:
Как это реализовать?
1. Приложить пример
2. Указать версию excel

=SUMPRODUCT(A1:A6;--ISTEXT(FORMULATEXT(A1:A6)))

Да , ниже более просто.
Изменено: БМВ - 24 Авг 2018 10:13:09
 
=СУММПРОИЗВ(C3:C4;--(ЕФОРМУЛА(C3:C4))), например для Excel 13
 
Эксель 2016.
Пример прилагаю.
------------------------

После загрузки увидел ответы. Спасибо большое, все прекрасно работает!
Изменено: memo - 24 Авг 2018 10:36:26
 
Всем добрый день.
Снова возникла проблема, на этот раз нужно, чтобы ячейки с формулами пропускались.
В конце, в ячейке DC  должно отображаться кол-во товара идентичное DA.
 
Изменено: memo - 3 Сен 2018 21:46:55
 
Цитата
memo написал:
загвоздка?
в том что формула считает правильно, а вот Вы что-то не так решили посчитать. Да и что-то я не понял, зачем такие сложности, вы ж просто считаете итог за месяц, почему не SUMIF?
 
Да, но в конце, в общем итоге надо пропустить столбцы с промежуточными итогами за месяцы в которых формулы.
 
Если из F каждый раз вычитать, а потом еще раз вычесть сумму того, что получилось при вычитаниях, то ну никак + не получится.
Изменено: БМВ - 4 Сен 2018 07:21:20
 
Да это и не требуется. Если после всех вычитаний получился 0, то он и должен остаться. Главное, чтобы в вычитаниях не участвовали столбцы с промежуточными итогами. Я предположил, что это можно организовать с помощью формулы, которая автоматически пропускала бы эти столбцы, руководствуясь тем, что в них формула.
 
memo,  Повторяю, формула считает корректно, посмотрите что вы хотите посчитать.
 
БМВ, Прошу прощения, поправил свой пост, где все сформулировал четче.
Теперь стоит задача пропускать при вычислениях столбцы в которых есть формула.  
 
=F3-SUMPRODUCT(G3:DB3*NOT(ISFORMULA(G3:DB3)))
Изменено: БМВ - 4 Сен 2018 07:21:40
 
Огромное спасибо!
По вашим постам и вправду можно многому научится!
Страницы: 1
Читают тему (гостей: 1)
Наверх