Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение данных в строке и выделение отличий
 
Добрый день.
Сразу прошу прощения, если не правильно назвала тему.
Вопрос вот в чём.
Есть список цветов, в разные месяцы они находились в группах (А, В, С).
Необходимо выделить те цвета (или в соседний столбец проставить любое значение, чтобы можно было их отфильтровать), у которых группа менялась (была одна, стала другая) при этом не важно в какой месяц и с какой группы на какую. Если в каком-то месяце нет значения группы, а потом группа остается той же, то это не считается изменением (т.е. пропускаем пустые ячейки).
Пробовала через ЕСЛИ(СЧЁТЕСЛИ, но в этом случае приходится перебирать все возможные варианты из 12 месяцев, что крайне громоздко, может есть способ по проще найти различия значений в строке?
Заранее спасибо :)
Пример.xlsx (9.78 КБ)  
 
Доброе время суток.
А что это формулисты спят!? Вариант - такое даже я могу!
Код
=ЕСЛИ((СЧЁТЕСЛИ(B2:H2;"C")>0)+(СЧЁТЕСЛИ(B2:H2;"B")>0)+(СЧЁТЕСЛИ(B2:H2;"A")>0)>1;"Да";"Нет")
 
Андрей VG, Только хотел отписаться :)
А у Вас еще и ответы с букавками…:)
 
Еще вариант
=СЧЁТ(1/СЧЁТЕСЛИ(B2:H2;{"A":"B":"C"}))

Показывает, сколько различных значений АВС в диапазоне
Единички - это нормально, всё, что больше - значения менялись.
Изменено: _Boroda_ - 3 Сен 2018 17:09:35
Скажи мне, кудесник, любимец ба’гов...

 
О! Андрей VG,  спасибо приогромнейшее :)
Вот ведь не сообразила сразу, что можно не сравнивать значения, а буквы прописать.
Страницы: 1
Читают тему (гостей: 1)
Наверх