Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммировать только те ячейки, где есть значение (а не #Н/Д)
 
Добрый день,

наверное тупой вопрос, но все же спрошу.

В ячейках выводятся результаты формул, соотв. там, где нет результата - стоит #Н/Д.

Когда начинаю суммировать  - не показывается результат, вот из-за этого #Н/Д.

Как заставить Эксель "не обращать на это внимание"?

Спасибо.
 
Обработать формулы функцией еслиошибка
Лень двигатель прогресса, доказано!!!
 
Пытался. Затупил на этапе "истина / ложь." Там же явно не текст Н/Д выбирать ? ...
 
Цитата
Route66 написал:
Затупил на этапе
Не только на этом, но и
Цитата
2.3. Приложите файл(ы) с примером (общим весом не более 300Кб) в реальной структуре и форматах данных того, что есть сейчас и того, что хотелось бы на выходе.
 
Еслиошибка(ваша формула;0)
Лень двигатель прогресса, доказано!!!
 
Ага. Приложил.
 
=ЕСЛИОШИБКА(ВПР(A3;baza!$A$1:$B$10;2;0);"")
либо
=СУММЕСЛИ(B3:E3;">0";B3:E3)
Как желаете
 
Функция Агрегат
 
Цитата
Александр написал:
=СУММЕСЛИ(B3:E3;">0";B3:E3)Как желаете

мне нужны определенные ячейки

=SUMIF(M3+Q3+U3,">0")

не работает
 
Цитата
Route66 написал:
M3+Q3+U3
они пустые, нормальный пример приложите как есть и что хотите
Лень двигатель прогресса, доказано!!!
 
А почему не подходит "Агрегат" параметр 6 пропускает ошибки при суммировании
 
Цитата
Route66 написал:
=SUMIF(M3+Q3+U3,">0")
смотрите критерии формулы
 
Цитата
Сергей написал:
они пустые, нормальный пример приложите как есть и что хотите
еще раз прикладываю.

должен суммировать значения столбов B и F, если таковые есть.
Изменено: Route66 - 4 Сен 2018 13:37:29
 
Из Вашего примера не вполне ясно следует ли возвращать сумму, если только одно из слагаемых возвращает ошибку - на всякий случай вернул :)
В том же случае, если этого не требуется, то замените выражение =ЕСЛИОШИБКА(ВПР(...);0) на =ЕСЛИОШИБКА(ВПР(...);"") и в результирующем столбце также используйте функцию ЕСЛИОШИБКА()
 
для примера размещенного IKor, с подавленными ошибками, отсеиваем ненужные столбцы по наименованию
Код
=СУММПРОИЗВ(--($B$1:$I$1="Price");$B3:$I3)
Лень двигатель прогресса, доказано!!!
 
вообще запутался.
возвращать сумму надо, даже если там 0.

у меня вообщке показывает

#МАКРОС?#МАКРОС?#Н/Д#Н/Д
 
Route66, возьмите свой пример который последний, подавите ошибки Н/Д как вам рекомендовали выше, потом вставьте мою формулу в J3 и растяните вниз
Лень двигатель прогресса, доказано!!!
 
Это, кстати, OpenOffice.

Это что-то меняет?
 
А у нас форум по Excel.
 
Цитата
Route66 написал: Это что-то меняет?
OFF В корне. Особенно если Оо древний, да еще на кривой оси. Относительно ближе к MSO кальк из LibO - сейчас это 6.1.0.3, но и тут без гарантий... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
Страницы: 1
Читают тему (гостей: 1)
Наверх