Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск значения по столбцам с прикреплением наименования того столбца, в которм значение найдено.
 
Доброй ночи. Мучаюсь уже который день. Дано: два листа со списками, на листе 1 нужно прописать формулу, которая будет искать значение в списках листа 2 и присваивать ячейке название того столбца, в котором значение найдено, а если этого значения нигде нет, то вывести слово "добавить".
Пробовала вложеные функции если, еслимн, еснд, еслиошибка, но у меня не получается прописать несколько условий...
Изменено: Татьяна Веселовская - 5 Сен 2018 15:16:39
С ув. Татьяна
 
veselochka,Здравствуйте, вариант
Код
=ЕСЛИ(СЧЁТЕСЛИ(лист2!$A$1:$E$33;[@Ингридиенты])>0;ИНДЕКС(лист2!$A$1:$E$1;СУММПРОИЗВ((лист2!$A$2:$E$33=[@Ингридиенты])*СТОЛБЕЦ($A$2:$E$33)));"Добавить")
На листе 2 не должно быть повторяющихся значений
 
Спасибо!!!, вроде работает, разбираюсь что откуда и куда!
Изменено: Татьяна - 5 Сен 2018 15:03:18
С ув. Татьяна
 
еще вариант
Код
=ИНДЕКС(лист2!$A$1:$F$1;МАКС((лист2!$A$2:$F$33=$A2)*СТОЛБЕЦ($A$1:$F$1)))
Лень двигатель прогресса, доказано!!!
 
В примере эта формула, как формула массива?
С ув. Татьяна
 
Татьяна, если про мою то да массивная
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх