Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Название продукта с наибольшими затратами
 
Здравствуйте! Имеется следующая проблема:
номенклатура товаров с более чем 5000 строк, товары повторяются, по каждому товару даны затраты. Необходимо вывести товар (наименование), по которому суммарные траты наибольшие. Ниже пример того, как все выглядит, и что нужно вывести. Как это можно сделать с помощью формул? Был вариант это сделать с функцией ИНДЕКС и МАКС, но в этом случае возникают промежуточные значения (сумма по товару), и ей ни одна ячейка не соответствует.
 
попробуйте
Код
=ИНДЕКС(A2:A10;ПОИСКПОЗ(МАКС(СУММЕСЛИ(A2:A10;A2:A10;B2:B10));СУММЕСЛИ(A2:A10;A2:A10;B2:B10)))

формула массива
Можете ещё с этой темой ознакомиться, возможно, полезной окажется. Похожая задача.
Изменено: Stics - 6 Сен 2018 14:15:41
 
Stics, думаю не лишним будет добавить 3-й аргумент в ПОИСКПОЗ:
=ИНДЕКС(A2:A10;ПОИСКПОЗ(МАКС(СУММЕСЛИ(A2:A10;A2:A10;B2:B10));СУММЕСЛИ(A2:A10;A2:A10;B2:B10);0))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, согласен, пропустил. Спасибо)
Страницы: 1
Читают тему (гостей: 1)
Наверх