Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск слова в ячейке из заданного списка
 
Добрый день.
Есть список производителей, есть список товаров, в наименовании которых есть имя производителя. Нужно его вытащить в отдельный столб.
Написал формулу, но она если не находит производителя из списка, то вставляет почему-то значение из поля А2 (см. пример).
Мне нужно, чтобы это поле оставалось пустым.
Код
=ИНДЕКС(Лист2!$A$2:$A$6;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСК(Лист2!$A$2:$A$6;Лист1!B2));СТРОКА(Лист2!$A$1:$A$5);"")))

Помогите с формулой, пожалуйста.
Спасибо!
 
Добрый день.
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК(Лист2!$A$1:$A$6;B2);Лист2!$A$1:$A$6);"")
 
Stics,Спасибо большое, все работает!
Страницы: 1
Читают тему (гостей: 1)
Наверх