Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формирование документа в зависимости от выбранного месяца, выборка из однотипных таблиц
 
Здравствуйте уважаемые.
как формировать документ из однотипных таблиц по названию месяцев т.е по выпадающему списку на листе «основной» и выборе нужного месяца, в «недельные планы» переносились данные из этого месяца, не городить же такие формулы в каждой ячейке :
«=ЕСЛИ(B3="январь";Выборка!B17;ЕСЛИ(B3="февраль";Выборка!B27;ЕСЛИ(B3="март";Выборка!B37;ЕСЛИ(B3="апрель";Выборка!B47;ЕСЛИ(B3="май";Выборка!B57;ЕСЛИ(B3="июнь";Выборка!B67;ЕСЛИ(B3="июль";Выборка!B77;ЕСЛИ(B3="август";Выборка!B87;ЕСЛИ(B3="сентябрь";Выборка!B97;ЕСЛИ(B3="октябрь";Выборка!B107;ЕСЛИ(B3="ноябрь";Выборка!B117;ЕСЛИ(B3="декабрь";Выборка!B7;"нет данных"))))))))))))
должно же быть более простое решение, что-бы не делать ещё кучу таблиц с недельными планами
 
edkudin,ипользуйте ВПР
 
edkudin, Все и лучше и хуже, INDIRECT (ДВССЫЛ кажется) поможет сделать формулу которая будет брать с листа определяемого лист боксом. Но она летучая и при любом чихе будут пересчитываться все ваши ячейки, даже если это и не нужно.
В примере не понятно что у вас как размещается, замените более наглядным примером  Вы выборку удалили?

ivanok_v2,  простите, но совет выглядит так, как будто файл вы не открывали.
Изменено: БМВ - 6 Сен 2018 20:10:02
 
Цитата
БМВ написал:
ivanok_v2 ,  простите, но совет выглядит так, как будто файл вы не открывали.
И это уже не в первый раз )
 
вот попытался изобразить что нужно, похоже на сводную таблицу но только надо подставлять данные или формировать лист только из одного листа-источника в зависимости от выбранного в выпадающем списке, если выбран "январь" то подставлять данные с листа "январь", если "сентябрь" то с "сентябрь" и т.д.
 
в файле своем на листе основной покажите что должно получится руками сделайте как это должно выглядеть, у вас там два выпадающих списка
Лень двигатель прогресса, доказано!!!
 
edkudin, Или картинка не для файла, или файл не для картинку.
если "Планируемые мероприятия" я еще как то понимаю, что это например "поездка во Владивосток" , то  "Время и  место проведения" это что?
Короче вот это ссылается на ячейку D5 выбранного листа в Основной!B3
=INDIRECT(ADDRESS(5;4;;;Основной!$B$3))
Принцип определения этих 5 и 4 мне не понятен.  
 
Вот для понимания вопроса накидал урезанный вариант на пару дней и пару месяцев. При выборе в списке на листе "основной" в "планах" меняются данные, берутся из эти месяцев.
Просто когда дело дойдет до реальны файлов, количество вложенных ЕСЛИ просто зашкаливает
 
Во вложении
=IFERROR(INDIRECT(ADDRESS(4;ROW()/9*2+3;;;Основной!$B$3));"")
=IFERROR(INDIRECT(ADDRESS(MOD(ROW()-5;9)+5;INT((ROW()-5)/9+1)*2+2;;;Основной!$B$3));"")
=IFERROR(IF(C14>0;INDIRECT(ADDRESS(MOD(ROW()-5;9)+5;2;;;Основной!$B$3));"");"")
 
вообщем не хотите слышать о чем вас просят
Цитата
Сергей написал:
на листе основной покажите что должно получится
пробуйте менять показатель в выпадающем смотрите что получается наводите красоту сами
Лень двигатель прогресса, доказано!!!
 
Всем огромное спасибо, разобрался и сделал как БМВ подсказал, да заодно в блоге интересности нашел, кое что себе облегчил
Страницы: 1
Читают тему (гостей: 1)
Наверх