Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Количество часов в заданном периоде
 
Добрый день!

Форумчане, можно ли решить мою задачу обычными методами

Суть в следующем:

Есть период дат и времени...Сегодня 07:00 и Сегодня()-1 07:00...

Необходимо подсчитать количество часов ремонта для строк в этом периоде сегодня 07:00 и сегодня()-1 07:00 .
При условии, что если не заполнено поле дата окончания ремонта, то мы считаем это за 24 часа...
 
так нужно?
=ЕСЛИ(C2="";G$1+G$2;C2+МИН(G$2;D2))-ЕСЛИ(A2<F$1;F$1+F$2;A2+МАКС(F$2;B2))
=ЕСЛИ(C2="";G$1+G$2;ЕСЛИ(C2>G$1;G$1+G$2;C2+МИН(G$2;D2)))-ЕСЛИ(A2<F$1;F$1+F$2;A2+МАКС(F$2;B2))
Изменено: Catboyun - 6 Сен 2018 21:21:58
 
Может так?
=IF((C2="")*(A2+B2<$G$1+$G$2);1;MAX(MIN($G$1+$G$2;C2+D2)-MAX($F$1+$F$2;A2+B2);0))
 
Да и так, и так считает вроде как..

Спасибо!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх