Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поискув строке по нескольким условиям
 
Добрый день,
Кто подскажет приемы по поиску в строке - по нескольким условиям одновременно...

если кратко, то в формуле  при не выполнении  одного из условий в функции ПОИСК или в  функции ЕСЛИ, генерится ошибка и результат всей формулы  также ошибка..  перехват  функцией ЕСЛИОШИБКА результата нужного не приносит ..

Например,  есть строки в колонке A,  ячейках A1, A2, ....A15000
АВВГ 3х4 мс(N, PE)-0.66
АВВГ 3х4 мк(N, PE)-1
................
.................

Нужна формула-
если в ячейке в строке   есть "мк" или "мс",  в ячейку колонки "В" нужно записать слово - "многожильный".
если в ячейке есть "ок"- нужно в ячейку колонки "В" записать слово -  "одножильный".
если в строке нет - "мк", "мс", "ок",  то нужно в ячейку колонки "В" записать слово "ошибка".

Использую функции  ЕСЛИ , ПОИСК, ЕСЛИОШИБКА

=ИЛИ(ПОИСК("мк";"A1"; 1);ПОИСК("мс";"A1"; 1))
 выдаст ошибку,  потому как одновременно в строке может быть или мк или мс.
результат #знач!

использование вложенных ЕСЛИ(ПОИСК("мк";"A1"; 1);"многожильный"; ЕСЛИ (ПОИСК("мс";"A1"; 1);"многожильный";"")
также результата нужного не приносит...
а ведь еще нужно добавить несколько вложений для поиска "ок"...и анализ отсутствия в строке "мк", "мс","ок"
Проблема в том, что в каждой строке выполняется корректно поиск только по одному из условий поиска.

кто подскажет идеи как корректно можно реализовать одновременный поиск в строке по многим условиям?

спасибо
 
Приложите пример и вашу формулу с ошибкой в ней.
 
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК("мс";A1));ЕЧИСЛО(ПОИСК("мк";A1)));"многожильный";ЕСЛИ(ЕЧИСЛО(ПОИСК("ок";A1));"одножильный";"ошибка"))
Лень двигатель прогресса, доказано!!!
 
Спасибо! Идею понял,  проверю как работает - отпишусь
Страницы: 1
Читают тему (гостей: 1)
Наверх