Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование с использование нескольких условий поиска или масок
 
Добрый день!
Уже облазил примеры и решения по СУММЕСЛИМН, СУММЕСЛИ, СУММПРОИЗВ, но мне не хватает понимания и мозгов)
Помогите пожалуйста.
Суть такая, надо вывести суммы ячеек по определенным кодам.
В примере не все данные, на самом деле коды у меня идут и дальше 001-200 001-300 и прочие, но вот в кодах 100 у меня есть особенность.
Для подсчета всех кодов 100 я могу использовать такое решение
=СУММЕСЛИ(A2:A200;"001-1*";B2:B200)
точно так же, если я захочу посчитать 001-11*
=СУММЕСЛИ(A2:A200;"001-11*";B2:B200)
А вот как мне посчитать сумму ячеек, которые соответствуют 001-103 001-106 001-119 001-117?
СУММПРОИЗВ у меня ничего не вышло, если указать (A2:A200="001-103")*(B2:B200), вернется искомый результат, но когда я добавляю новые массивы, я явно что-то делают не так т.к. он возвращает ответ первого массива и добавляет еденицу как число второго массива.
 
два варианта
Код
=СУММПРОИЗВ((((A2:A200="001-103")+(A2:A200="001-106")+(A2:A200="001-119"))>0)*(B2:B200))
=СУММПРОИЗВ(СУММЕСЛИ(A2:A200;{"001-103";"001-106";"001-119"};B2:B200))
Лень двигатель прогресса, доказано!!!
 
Сергей,супер! Большое спасибо, работает отлично)))
Пара вопросов, в 1 варианте >0 сделано просто для надежности? Работает вроде и без этого.
А вот по второму мне просто тупо не понятно, я в принципе конструкцию подобную по СУММЕСЛИ пробовал, почему она отдельно не работает, а только внутри функции СУММПРОИЗВ?
 
В G2:G11 список кодов для подсчета, тогда сумма
=СУММПРОИЗВ(СУММЕСЛИ(A:A;G2:G11;B:B))
или, если коды четко определены, то
=СУММПРОИЗВ(СУММЕСЛИ(A:A;{"001-103":"001-106":"001-117":"001-119"};B:B))
В файле еще автораскраску Условным форматированием сделал и вып. списки для выбора кодовПроверкой данных
Скажи мне, кудесник, любимец ба’гов...

 
Цитата
GreyAlex написал:
сделано просто для надежности
ну можно сказать и так просто взял то что делал сам недавно, просто у меня условия отслеживались в разных столбцах и при совпадении одной позиции в двух столбцах по одной строке сумма бы удваивалась
Лень двигатель прогресса, доказано!!!
 
_Boroda_, Сергей, большое спасибо!)
Страницы: 1
Читают тему (гостей: 1)
Наверх