Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выводить коэффициент в зависимости от плюсовых и минусовых температур
 
Добрый день.
В ячейке I6 значение температуры вводится вручную.
В ячейке В30 должен выводится коэффициент в зависимости от температуры (I6).
Диапазоны температур и соответствующие коэффициенты забиты в формулу. Но формула не работает.
Что нужно сделать, чтоб она заработала?
 
Цитата
...25>I6>20...
Такая запись интервалов в формулах не допустима. Пишется так
Код
=ЕСЛИ(И(I6>20;I6<25);....
Согласие есть продукт при полном непротивлении сторон.
 
Однако - как возможный вариант - "В итоге все свелось к уроку по пользованию интервальным поиском"
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
так 25>I6>20  не работает ,  И(I6>20;I<25)  и посмотрите на ваши диапазоны условий, куда например должно попасть 5
 
Vik_tor, ввела так:
=ЕСЛИ(И(I6>20;I6<25);"3,37";ЕСЛИ(И(I6>26;I6<30);"4,72";ЕСЛИ(И(I6>30);"6,74";ЕСЛИ(И(I6>(-5);I6<5);"0,337";ЕСЛИ(И(I6>(-15);I6<(-6));"1,011";ЕСЛИ(И(I6<(-26));"1,348";ЕСЛИ(И(I6>6;I6<19);0;"")))))))
Не работает. Видимо неправильно ввожу и дальше?

 
Покажите в файле (просто, в виде отдельной таблицы) какой коэффициент какому интервалу температур должен соответствовать. И какой коэфф. должен быть при температуре РАВНОЙ, например, 25? Или -6? Ну и так по всем граничным значениям
Согласие есть продукт при полном непротивлении сторон.
 
Sanja, спасибо за терпение)
Вот таблица с диапазонами.  
При температуре 25 коэфф. равен 3,37.
То есть, 20-25 включает и 20 и 25.
 
=ВПР(B2;B4:C12;2)
 
vikttur, как просто и красиво) Спасибо большое!
Страницы: 1
Читают тему (гостей: 1)
Наверх