Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Определение нужного значения в зависимости от других данных
 
Здравствуйте.
Нужна помощь в создании следующей формулы:

Есть товар с разным количеством, если его количество меньше или равно 1 (колонка B) то значение в ячейке (колонка C) =0, если больше 1, то значение в ячейке =1.
 
Chemurash, используйте формулу "если"
 
ivanok_v2,понимаю прекрасно, что надо использовать ЕСЛИ, но как?

Как прописать условие, что если B1<=1 то B2=0 ?

Сказать могу, сделать пока не знаю как
 
Цитата
Chemurash написал: сделать пока не знаю как
Чаще жмите F1 и внимательно читайте... ;)
Код
=ЕСЛИ(B2<=1;0;1)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Z,Спасибо тебе, добрый человек)
 
=--(B2>1)
 
БМВ, +++! Теперь тоже буду знать, что "ИСТИНА" и "ЛОЖЬ" можно вот так просто в 1 и 0 ! СПАСИБО!
 
Z,рано обрадовался я.
Вставил формулу в свой массив.
В итоге выдает все единицы в столбце
Формулу проверил, все верно. Что не так делаю?
2-4.png (59.64 КБ)
 
Chemurash,  зачем же весь столбец то сравнивать?
 
Цитата
Chemurash написал:
Формулу проверил, все верно
Цитата
Z написал:
=ЕСЛИ(B2<=1;0;1)
Цитата
БМВ написал:
=--(B2>1)
А у Вас: G:G
Как Вы думаете, что означают в формуле  цифры после букв?
 
БМВ, пример был для примера и чтобы не путать лишний раз
В реальности данных больше, естеcтвенно требуется сравнивать не одну ячейку.
Если поставить в формулу только одну ячейку, эффект такой же
2-5.png (71.69 КБ)
 
Chemurash, так и ответ был для примера. Что и как вы вводите и включен ли у вас пересчет - нам не ведамо.
 
Цитата
_Igor_61 написал:
А у Вас: G:GКак Вы думаете, что означают в формуле  цифры после букв?
_Igor_61,я специально в сообщении чуть выше написал, это был пример!
В файле был пример.
Зачем для примера приводить 7-8 колонок информации которая в расчетах не используется?
На картинке приведет рабочий массив с реальными данными.
 
Chemurash, а вы сами не видите что на вашей картинке G40 и тд больше 1 а формула вам возвращает истину вас ни чего не напрягает логически
Лень двигатель прогресса, доказано!!!
 
БМВ,что и как я ввожу видно. Формула присутствует.
Подскажите, что такое перерасчет?
Как им воспользоваться, если вообще необходимо?
 
Сергей, по логике при 1 должен быть 0. Но что там введено и на что ссылается. кто знает.
 
БМВ,да попутал ну логика явно нарушена  
Лень двигатель прогресса, доказано!!!
 
Цитата
Chemurash написал:
перерасчет
Calculation  - Auto. Если нажать на F9 случаем ничего не происходит?
 
В русской версии вкладка формулы перерасчет галка должна быть на автоматически
Лень двигатель прогресса, доказано!!!
 
Цитата
БМВ написал:
Calculation  - Auto. Если нажать на F9 случаем ничего не происходит?
К сожалению, нет.
Нужного процесса не происходит.
Гаснет экран.
 
Цитата
Сергей написал:
В русской версии вкладка формулы перерасчет галка должна быть на автоматически

вот так у меня на данный момент в параметрах установлено.
может все таки в этом проблема?
2-6.png (126.74 КБ)
 
Цитата
Chemurash написал:
Гаснет экран.
А таймер обратного отсчета не начинает тикакать? :-)

Если серьезно, сделайте пример из вашего файла с введенной формулой на несколько  строк,
 
вот пример с несколькими строками.
 
Цитата
Chemurash написал:
Гаснет экран.
Класс! БМВ, ну такого добиться всего двумя минусами...  в формуле... Когда я куплю Apple или Microsoft, возьму Вас Главным (конечно, если Вы согласитесь)      :)  
 
_Igor_61, Не надо покупать , Яблок, хоть и не урожай в этом году, пришлю, окна - тоже есть пара лишних :-)

Chemurash,  У вас в данных например 15 , ну и 1 - не числа а текст. Видимо в настройках выключена опция предупреждать об этом и на картинке мы этого не видим. Вот по этому нужен пример полноценный
Ну или приводить в порядок данные  или =--(--G2>1)
 
БМВ,Спасибо Вам огромное!
Все заработало как надо!

=--(--G2>1)  работает "на ура"!
Страницы: 1
Читают тему (гостей: 1)
Наверх