Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Оценка совокупных доходов за различные интервалы времени для разных счетов
 
Добрый день!

Имеется следующая проблема.
Есть набор данных отражающий изменение состояния счетов по месяцам. Необходимо создать функцию, позволяющую при вводе номера счета в ячейку оценить совокупный доход по счету за все время (интервалы времени - месяцы, однако количество месяцев для каждого счета разное)

Реально ли это сделать?  Для наглядности прилагаю пример.  
 
Если не обращать внимания на график, которого нет в вопросе:
Код
=СУММЕСЛИ(A3:A15;G2;C3:C15)
И нужно предложить изменение названия темы -  фразы "за различные интервалы времени для разных счетов" и  "по счету за все время (интервалы времени - месяцы, однако количество месяцев для каждого счета разное)" имеют, как минимум, три противоречия.
 
График был предназначен для другой части вопроса (не влезающей в одну тему) Спасибо большое! Все работает. .

P. S. Под "различными интервалами" имелось в виду то, что у каждого счета интервал времени совокупно разный.
 
Доброе время суток.
Версия на SQL. Файл сохранить в папку c:\path. На листе отчёт вводим номер счёта. Получаем результат, включая график ;)
 
Андрей VG, работает. Очень круто. Не могли бы Вы поделиться секретом, как это можно сделать?  
 
Цитата
RGE написал:
Не могли бы Вы поделиться секретом, как это можно сделать?  
Просто организовано два SQL запроса с параметром к листу Исходные, плюс значение параметра связано с ячейкой и установлен флаг автоматического обновления. Можете посмотреть в свойствах подключений книги. Плюс, декоративное оформление. При желании можно добавить выпадающий список для выбора счетов, существующих на листе Исходные.
У похода есть недостаток. При перемещении/переименовании файла необходимо в запросах в строках подключений указать новое местоположение и имя файла.
Страницы: 1
Читают тему (гостей: 1)
Наверх