Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти значение по столбцу и записать из ячейки
 
Добрый день.

Помогите, пожалуйста, решить задачу.
Нужно формулой взять значение из ячейки A2, осуществить точный поиск по столбцу D. Если значение найдено, записать в ячейку B2 соответствующее значение из столбца K.
Пробовал сделать формулой ВПР, не получается (пример в прикрепленном файле).
 
ВПР - диапазон не закреплен, состоит только из одного столбца, отсчитывать количество столбцов нужно от первого столбца диапазона
 
=ИНДЕКС($D$2:$K$21;ПОИСКПОЗ(A2;$D$2:$D$21;0);08)
08 - читать 8
Изменено: RAN - 9 Сен 2018 11:00:06
 
У Вас неправильная попытка использования ВПР:
Код
=ВПР(A2;D2:D21;11;ЛОЖЬ)
Ошибка #ССЫЛКА  в данном случае говорит о том, что номер столбца (второй параметр - 11) больше количества столбцов в таблице, которая у Вас задана диапазоном D2:D21 - здесь всего один столбец. Таблица должна охватывать возвращаемый столбец, т.е. D2:K21, теперь столбцов восемь и возвращать нужно не 11 а 8 столбец;
При растягивании формулы у Вас сместился диапазон в котором идет просмотр  - в строке 2 это D2:D21, в 3 - D3:D22, а в 21 - D21:D40. Необходимо изменить относительные ссылки на абсолютные, т.е. в качестве диапазона указать D$2:K$21 или, если придется копировать формулу вправо-влево, то $D$2:$K$21.
После исправлений формула будет иметь вид:
Код
=ВПР(A2;$D$2:$K$21;8;ЛОЖЬ)
а Вам рекомендую почитать про функцию ВПР и про типы ссылок на ячейки.
Изменено: Alec Perle - 9 Сен 2018 11:29:08
 
извините, разобрался. все правильно находят формулы (в файле были задублированы значения). Большое спасибо за помощь.  
Страницы: 1
Читают тему (гостей: 1)
Наверх