Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматический расчет новых значений с учетом повторений
 
Всем добрый день!
Прошу помочь в моем задании по автоматизации расчета премирования и депремирования сотрудников.
На примере в ячейках D2 и D4 указаны 2 нарушения.
Предполагается, что формула посчитает количество повторений, сверится с таблицей и установит сумму штрафа за первичное нарушение 100 руб., а за повторное 200 руб. Информацию можно увидеть в excel файле или скриншоте.  
 
Цитата
ЗАПРЕЩЕНО: 3.5. Рекламировать (использовать) в сообщениях, подписях, именах...
Измените логин
 
Логин успешно изменен.
 
Почему "Не уложился в установленный интервал" штраф 200 рублей для этой таблицы это первое нарушение и должно быть 100, вот вариант если логику понял
Код
=ИНДЕКС($G$10:$L$12;ПОИСКПОЗ(E2;$F$10:$F$12;0);СЧЁТЕСЛИМН($E$2:E2;E2;$G$2:G2;G2))
Лень двигатель прогресса, доказано!!!
 
Strizh, То же самое, что и в #4 , только, если будет больше повторений нарушения чем в таблице штрафов, не будет ошибки
Изменено: Александр П. - 10 Сен 2018 08:22:17
 
[USER=65394]Александр П.,  Сергей[/USER], огромное Вам спасибо!
2 дня пытался сделать формулу, но не знал про сочетание "поискпоз(счетеслимн("
Страницы: 1
Читают тему (гостей: 1)
Наверх