Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Деление 2х динамических массивов и получение суммы
 
Доброго времени суток, столкнулся с такой проблемой мне нужно поделить один диапазон на другой и их сумму сложить, казалось бы ничего сложного, СУММПРОИЗВ тебе в помощь, но есть одна проблема, ну или моя заморочка количество значений может меняться в зависимости от ситуации... И я хотел бы не "растягивать за ручки" диапазон а просто его расширить но сто бы функция СУММПРОИЗВ НЕ учитывала пустые ячейки при расчете... Я уже все попробовал что мог... Помогите пожалуйста с этой проблемой... Файл приложил...
 
Diplomatik, добрый день, теме нужно давать осознанное название, что вы хотите сделать, а не с помощью чего. Вариант для названия темы: Деление 2х динамических массивов и получение суммы.

Вот вариант  
Изменено: a.i.mershik - 10 Сен 2018 10:01:53
 
Благодарю, к сожалению я не знал как правильно ее описать... Простите мою не грамотность...
 
Еще вариант:
=СУММПРОИЗВ(A10:ИНДЕКС(10:10;СЧЁТЗ(10:10))/A11:ИНДЕКС(11:11;СЧЁТЗ(11:11)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Доброго времени суток.
Можно формулу массива ввести.
{=СУММПРОИЗВ(A10:D10/ЕСЛИ(A11:D11=0;1;A11:D11))}
 
Цитата
Михаил Лебедев написал:
Можно формулу массива ввести.{=СУММПРОИЗВ(A10:D10/ЕСЛИ(A11:D11=0;1;A11:D11))}
Данная формула не работает(

Цитата
Bema написал:
Еще вариант:=СУММПРОИЗВ(A10:ИНДЕКС(10:10;СЧЁТЗ(10:10))/A11:ИНДЕКС(11:11;СЧЁТЗ(11:11)))
Этот вариант мне нравится больше )
Всем большое спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх