Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование по заданным условиям в двумерном массиве, Суммирование в двумерном массиве
 
Добрый день! Прошу помочь в такой задаче: в двумерном массиве необходимо выполнить суммирование всех ячеек попадающих между условием №1 и №2, при этом соответствовать выбранному судну (Условие №3). Надеюсь понятно объяснил, а то иногда излагать мысли письменно сложнее чем устно =)

Во вложении в отметил!
 
Почему ищете судно №2 а суммируете судно№3
Код
=СУММЕСЛИМН(ИНДЕКС(B:P;;ПОИСКПОЗ(S22;$B$14:$P$14;0));B:B;">="&S20;B:B;"<="&S21)
Лень двигатель прогресса, доказано!!!
 
Kentavrik,еще вариант
Код
=СУММПРОИЗВ(($B$15:$B$106<=$S$21)*($B$15:$B$106>=$S$20)*($C$14:$P$14=$S$22);$C$15:$P$106)
 
Сори за ошибку "Судно №3"
 
Работает! Спасибо за помошь
Страницы: 1
Читают тему (гостей: 1)
Наверх