Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск парных чисел в динамическом диапазоне.
 
  Добрый день!Есть таблица.В одной указываются парные числа искомые.А в другой ряд, где их надо найти .Синий ряд это как должно получиться с указанием номера строки .Как можно переделать формулу с сохранением ДВССЫЛ ,чтобы искались  только те числа  что указаны в первой таблице.Формула в прилагаемом файле
.Книга1.xlsx (13.13 КБ)  
 
nikkosar, а что собственно нужно получить информациюю как в столбце P??? или что? какой результат должен быть!?
Изменено: a.i.mershik - 10 Сен 2018 11:30:12
 
как в столбце P
 
nikkosar, надеюсь понял правильно, формула в ячейках столбца P
 
А можно ли вашей формуле использовать ДВССЫЛ.Так как зеленый ряд будет удалятся  со смещением вверх.
 
Не так написал.Как добавить ДВССЫЛ.
 
nikkosar, у вас тема называется поиск парных чисел - про динамический диапазон ничего не сказано)
т.е. в итоге Вам нужно что то другое... наверное нужно правильнее сформулировать название темы.
 
2 nikkostar
Обратите внимание на то, что Ваша функция (в столбце M) возвращает не совсем те значения, что указаны в столбце P

Если говорить именно о ее упрощении, то можно использовать
Код
=--(СУММ(СЧЁТЕСЛИ(G3:J3;C$3);СЧЁТЕСЛИ(G3:J3;D$3);СЧЁТЕСЛИ(G3:J3;E$3);СЧЁТЕСЛИ(G3:J3;F$3))>0)
или формулу массива
Код
{=--(СУММ(СЧЁТЕСЛИ(G3:J3;C$3:F$3))>0)}

Если же строки, содержащие лишь одно из "поисковых числе" не требуется помечать, то работает вышеприведенная формула
 
Извините понял.Насчет темы наверное правильно будет . Поиск  пары чисел при динамическом диапазоне.Ваша формула подходит.Можно ли ее как нибудь переделать Так как в таблице 1 ряд всегда будет удаляться со смещением вверх.И будет появляться новая пара  чисел
 
nikkosar, Вы кому отвечаете??
т.е. строка с искомыми значениями будет удаляться?  в P3 и протянуть
Код
=ЕСЛИ(СУММПРОИЗВ((G3:J3=ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($C:$C;ПОИСКПОЗ("яяяяя";C:C;1)+1;1))))*G3:J3)>0;ЕСЛИ(СУММПРОИЗВ((G3:J3=ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($D:$D;ПОИСКПОЗ("яяяяя";D:D;1)+1;1))))*G3:J3)>0;1;0);0)
Изменено: a.i.mershik - 10 Сен 2018 12:34:38
 
С вахты приехал еще не отошел от поездки.Извините.IKor в L и M возвращает 1 если совпало хотя бы одно число.А в колонке P нужно что бы совпало 2 числа(если совпадает одно число тогда возвращает ноль)
Прикрепил измененный файл.Так как дал не полную информацию.
a.i.mershik Ваша формула подходит но я не подумал уточнить.Что критерием поиска еще будет число 0.
 
Цитата
L и M возвращает...
а теперь в файл посмотрите.
Как помогать при таком безалаберном отношении к ответу?
 
IKor он только упростил формулу для поиска  совпадения хотя бы одного числа.Спасибо ему.Но мне надо чтоб совпали сразу два числа.Формула a.i.mershik подходит ,
Но когда критерием поиска становиться число  ноль.То она не корректно работает.Тоесть если в первой колонки таблицы будет ноль и во второй будет ноль то она возвращает ноль.А мне надо чтоб возвращала 1.Так как два числа совпало.
 
vikttur Ответы вроде есть.Но они не полностью раскрыты.
 
Цитата
nikkosar написал:
Но когда критерием поиска становиться число  ноль.То она не корректно работает.
Если все пустые ячейки (во второй таблице) будут гарантировано заполнены не числовыми данными (например "-"), то немного модифицированная функция a.i.mershik'а должна работать
Код
=ЕСЛИ(СУММПРОИЗВ(--(G3:J3=$C$3))>0;ЕСЛИ(СУММПРОИЗВ(--(G3:J3=$D$3))>0;1;0);0)
 
Изменено: IKor - 10 Сен 2018 15:39:52
 
a.i.mershik   В начале отвечал одному, потом другому.Пока медленно печатал не туда сообщения вставлялись.И да не обратил внимания что сообщения у вас Изменено: a.i.mershik - 10 Сен 2018 12:34:38.Следующий раз внимательно буду все сообщения перечитывать.
Скорость интернета очень медленная.
 
a.i.mershik  Большое спасибо то что нужно.
IKor и вам тоже  большое спасибо.IKor Внес ваши изменения в новую формулу a.i.mershik
=ЕСЛИ(СУММПРОИЗВ(--(G27:J27=ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($C:$C;ПОИСКПОЗ("яяяяя";C:C;1)+1;1)))))>0;ЕСЛИ(СУММПРОИЗВ(--(G27:J27=ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($D:$D;ПОИСКПОЗ("яяяяя";D:D;1)+1;1)))))>0;1;0);0).
При нулях в двух таблицах выдает 1.То что нужно.А вот при значениях 0 и "_" в первой таблице и значениях 0 и 0 во второй все равно 1.Что можно еще исправить
 
nikkosar,  чет намудрил какой-то ад)))
ну может кто подскажет элегантное решение... обязательно в С2 и D2 = должен быть текст.
Код
=ЕСЛИ(ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($C:$C;ПОИСКПОЗ("яяяяя";C:C;1)+1;1)))=ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($D:$D;ПОИСКПОЗ("яяяяя";D:D;1)+1;1)));ЕСЛИ(СЧЁТЕСЛИ(G3:J3;ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($C:$C;ПОИСКПОЗ("яяяяя";C:C;1)+1;1))))>1;1;0);ЕСЛИ(СЧЁТЕСЛИ(G3:J3;ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($C:$C;ПОИСКПОЗ("яяяяя";C:C;1)+1;1))))>=1;ЕСЛИ(ЕСЛИ(СЧЁТЕСЛИ(G3:J3;ДВССЫЛ(ЯЧЕЙКА("адрес";ИНДЕКС($D:$D;ПОИСКПОЗ("яяяяя";D:D;1)+1;1))))>=1;1;0);1;0);0))
Изменено: a.i.mershik - 10 Сен 2018 16:47:41
 
Спасибо всем кто откликнулся.Заместо пустых ячеек буду ставить число 999.Проблема решена.Буду упрощать формулу.Методом тыка
Страницы: 1
Читают тему (гостей: 1)
Наверх