Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Замена содержимого при совпадении данных в двух столбцах
 
Добрый день, стоит следующая задача:

Дано:
столбец А, где 3000 строк номеров вместе с названием организации.
столбец В, где только номера организаций, которые дублируются, их около 7000

Цель:
аменить содержимое в столбце В содержимым столбца А, при совпадении номеров обоих столбцов. Чтобы в столбцах В тоже были названия организаций
Изменено: Recedive - 10 Сен 2018 16:51:26
 
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(RC[-2]&" ";RC[-3];1));RC[-3];RC[-2])
Потом спецвставкой заменяете.
Изменено: StoTisteg - 10 Сен 2018 16:29:33
 
StoTisteg,Выдает ошибку
Изменено: Recedive - 10 Сен 2018 17:25:27
 
У Вас столбцы именованы буквами. Формула для другого типа ссылок.
 
Recedive, вставляете формулу В СВОБОДНЫЙ СТОЛБЕЦ, потом копируете и вставляете в ст.В ЗНАЧЕНИЯ.
Код
=ВПР(B2&" *";A:A;1;)
Изменено: Казанский - 10 Сен 2018 16:58:25
 
Казанский,Спасибо, помогло
Страницы: 1
Читают тему (гостей: 1)
Наверх