Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Оценка исходя из возраста, категории, баллов, возрастной группы
 
Здравствуйте. Создал документ для быстрого подсчета оценки по физической культуре... дошел до этапа выставления оценки и столкнулся с проблемой: как выставить оценку, зная баллы, которые нужно сравнить с таблицей по возрастным группам. Как я понял, нужно полученные баллы сравнить с баллами в строке где совпадут столбцы "возраст" и "категория", найти приближенный результат и выставить оценку. Подскажите как можно реализовать эту задумку
 
tkvictor, Если чуть реорганизовать данные на листе группы, то можно вот таким способом. Добавлен столбец К - для удобства поиска значений.
Код
=ИНДЕКС(Группы!$A:$K;1;ПОИСКПОЗ(Q2;ДВССЫЛ("Группы!A"&ПОИСКПОЗ([@Возраст]&[@Категория];Группы!$K:$K;0)&":G"&ПОИСКПОЗ([@Возраст]&[@Категория];Группы!$K:$K;0));1))
 
Спасибо a.i.mershik, результат выкладываю, может кому пригодится
Страницы: 1
Читают тему (гостей: 2)
Наверх