Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вставка из массива по условию
 
Добрый день.
Подскажите, пожалуйста, как написать формулу. Есть столбец с текстом, где слово-фильтр циклически повторяется каждую четвертую строку. И есть еще столбец с данными, откуда надо брать значения для вставки. Задача - раскидать значения из этого массива только в те строки, где встречается слово-фильтр.

Наверное, криво объяснил, поэтому поясняю рисунком.

Создал формулу =ЕСЛИ(G215="Local"; ИНДЕКС(V195:V278; 1); ""), но при растягивании вставляется не следующее значение массива, а каждое четвертое.
massiv1.JPG (68.09 КБ)
 
День добрый!
Лучше если Вы вставите пример в вложение, а то как людям тут колдовать? Самим пример создавать  
 
А так, можно через =ИНДЕКС(V195:V300;ЕСЛИ(F195=2;ПРОСМОТР(999999;К1:К300)+1;F194))
Но ее надо проверять и подгонять в примере
 
без файла как то так
Код
=ЕСЛИ(G195="Local"; ИНДЕКС($V$195:$V$278;СЧЕТЕСЛИ($V$195:V195;$V$195); "")


П.С. почитайте про абсолютные и относительные ссылки.
Изменено: V - 12 Сен 2018 14:07:20
 
V,  Вы случайно не так хотели?
=ЕСЛИ(G195="Local";ИНДЕКС(V$195:V$278;СЧЕТЕСЛИ(G$195:G195;G195); "")
Изменено: _Boroda_ - 12 Сен 2018 14:19:46
Скажи мне, кудесник, любимец ба’гов...

 
_Boroda_, вы гений! Ваш вариант заработал! Столбец Formula3 в файле.

Теперь убейте меня, если я понял, как это сделано.


Александр, V, спасибо за помощь. Но ваши не взлетели. Formula 1 и 2 соответственно. Впрочем, мог накосячить при воспроизведении формул.
 
_Boroda_, да так. :) не то скопировал. :)
 
С файлом вариант попроще  :D
=ЕСЛИ(A2+D2;"";ИНДЕКС(I:I;СТРОКА(F8)/4))
Скажи мне, кудесник, любимец ба’гов...

 
Цитата
_Boroda_ написал:
вариант попроще
Блин, не успел. Почти тоже самое написал :D .
Изменено: Bema - 12 Сен 2018 14:51:41
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх