Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Обучающий калькулятор для суммирования дробей., Кто может натолкнуть на идею или помочь решить?
 
Кто может натолкнуть на идею или помочь решить?

Дополнение: Математическая операция (плюс, минус, деление, умножение) должны выбираться с выпадающего меню - соответственно влиять на формулу.
Снимок1.PNG (4.27 КБ)
Изменено: incarnus - 13 Сен 2018 10:00:07
 
А что тут решать? И каким боком Эксель к этой картинке?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
incarnus,
1.Какое отношение ваше собщение имеет к екселю?
2.Учите основы метематики, так как то что там написано верно.
 
Как каким? в ячейках надо сделать решение дробей.
Математически я конечно могу их решить. Но вопрос как решить задачу автоматического счета с ячеек
Изменено: incarnus - 12 Сен 2018 17:01:08
 
Цитата
incarnus написал:
Математически я конечно могу их решить
как математически, точно также и в ексель формулами
Код
=A1+B1
и т.д
 
Цитата
Bema написал:
И каким боком Эксель к этой картинке?
левым, там с боку номера строк :-)

incarnus, Еслиб вы не прогуливали школу, то решение было у вас на поверхности
=b2/b4+d3+e2/e4
Особенно мне нравится E2 E4 :-)

P.S. А почему "з дробями"?
Изменено: БМВ - 12 Сен 2018 17:08:59
 
incarnus,формат ячеек -> дробный

БМВ, скорее всего - Украина
Не стреляйте в тапера - он играет как может.
 
Цитата
БМВ написал:
incarnus , Еслиб вы не прогуливали школу, то решение было у вас на поверхности =b2/b4+d3+e2/e4Особенно мне нравится E2 E4 :-)
ага. это если число выйдет целое, а если дробное - тогда как дробную часть вывести?
 
Цитата
Ts.Soft написал:
incarnus ,формат ячеек -> дробный БМВ , скорее всего - Украина
Ts.Soft, - не катит - формат ввода вовсе не тот.  
Изменено: incarnus - 12 Сен 2018 17:25:53
 
Цитата
БМВ написал:
=b2/b4+d3+e2/e4
БМВ,а колонки тоже
угадывать? )))
Цитата
не катит
интересный жаргон разговора.
Изменено: ivanok_v2 - 12 Сен 2018 17:31:40
 
Куда вывести? Вас не научили переводить из десятичных в простые? В любом случае тема ни к черту. Дробей то нет. Так же как и внятного поимера нет.
 
см.вложение (нули только не пишите в знаменатели)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
тему можно назвать;
обучающий калькулятор для складывания дробей
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко,почти идеально. спасибо большое.
как переименовать тему я не в курсе - новичок на форуме.
но что делать при таком раскладе? как убрать дробь в ответе? условным форматировением?
2.PNG (1.93 КБ)
 
исправил. снял защиту.
изучайте формулы в колонках 7, 8, 9, 10, 11))
удачи!
а название темы поменяет кто-то из модераторов, если сочтет нужным.
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Еще можно получить ответ в виде дроби с помощью формулы =ТЕКСТ(A1+B1/B4+D1+E1/E4;"0"" ""???/???")
и разобрать на части текстовыми функциями. Целое там получается целым.
 
Допилил с учетом отрицательных  8)
 
немного модифицированный вариант от Казанский,
 
Казанский, БМВ, Ігор Гончаренко, усовершенствовал задачу Казанский, но не работает умножение почему-то. кто подскажет?
в Ігор Гончаренко ошибка в формуле-кто будет пользоваться.
Изменено: incarnus - 13 Сен 2018 11:28:53
 
incarnus,  добавьте в M3 к * пробел  или замените * на X.
 
или так
Код
=ВПР("~"&$C$2;$M$1:$N$4;2;0)
 
(A1+SIGN(A1)*B1/B4)*(D1+SIGN(D1)*E1/E4)^CHOOSE(CODE(C2)-41;1;0;0;0;0;-1) +(D1+SIGN(D1)*E1/E4)*CHOOSE(CODE(C2)-41;0;1;0;-1;0;0)
Страницы: 1
Читают тему (гостей: 1)
Наверх