Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
как подставить значение с транспортированием
 
Уважаемые Форумчане, прошу подсказки как можно вытащить название колонок из листа 2  и прописать их как заголовки колонок листа 1. по условию  в ячейке A4 Заранее благодарен
Изменено: alex1210 - 13 Сен 2018 05:27:38
 
1. Скопировать блок ячеек F2:E17 листа Лист2
2. Встать в яч.А4 на Лист1, ПКМ, Параметры вставки-"Транспонировать (А)"
 
Уупс, не так понял, точнее понял, но не так. Что-то мне кажется дело не в транспонировании. Можно еще раз, что куда и по какому условию.
Изменено: БМВ - 13 Сен 2018 07:29:37
 
БМВ,доброго дня, просто в если ячейке А4 = ПРС53, то загружаются все данные с со столбца А лист2, если А4 =ПРС54 лист2, то со столбца С, если А4 = КУ 1364 со столбца Е лист2, но загружаются не в столбик а в ряд начиная со столбца С. диапазон С:D это заголовки к столбцам.  
 
Михаил Лебедев, доброго времени, это то понятно ,но надо автоматически, а критерй в ячейке А4 лист1
 
alex1210,Так ?
 
Вариант. Вставляем в ячейку А4 протягиваем вправо и вниз, для скрытия нулей формат ячейки "Основной;;"
=ИНДЕКС(Лист2!$A$2:$E$17;СТОЛБЕЦ(A1);СТРОКА(A1))
 
Александр П.,Да, спасибо большое
 
AleksSid,доброго времени, в ячейке А4 данные будут вводиться руками, строке 2 не должно быть ничего
 
AleksSid - здорово! :excl:
 
Александр П., подскажите, почему когда смещаю диапазон вправа выскакивает ошибка
 
alex1210,Замените в формуле СТОЛБЕЦ() на СТОЛБЕЦ(C4)
Массив то из 16 строк. а столбец DT - 124й
Изменено: Александр П. - 13 Сен 2018 08:51:04
 
Александр П.,помогло только в первой колонке, дальше ошибка
 
Цитата
alex1210 написал:
в ячейке А4 данные будут вводиться руками, строке 2 не должно быть ничего
Можно так.
=ГПР($A4;Лист2!$A$2:$E$17;СТОЛБЕЦ();0)
 
Цитата
alex1210 написал:
дальше ошибка
Где ?
 
Александр П.,точнее если меняю по всей строке ,то копируеся первое название во всех колонках
 
Так?
=IF(COLUMN()>COUNTA(INDEX(Лист2!$A:$E;;MATCH(Лист1!$A4;Лист2!$2:$2;)))+1;"";INDEX(Лист2!$A:$E;COLUMN()+1;MATCH(Лист1!$A4;Лист2!$2:$2;)))
 
Александр П.,ааа понял ,я просто везде менял на С4
 
БМВ,здравствуйте ,спасибо за помощь подскажите я также подвигаю вправа до 124 колонки, тоже надо менять СТОЛБЕЦ()?  
 
AleksSid, да спасибо заработало, если смещать вправо, как формула поменяется если сместится до 124 столбца
 
alex1210, Что значит подвигаю? Подвигать - Побуждать :-) . Если просто тянете  в право, для охвата большего количества строк с листа 2, то ничего не надо.
 
Цитата
alex1210 написал:
как формула поменяется если сместится до 124 столбца
Измените размер диапазона, например  $A$2:$E$200, если будут добавляться еще столбцы увеличьте диапазон и в ширину, например
=ГПР($A4;Лист2!$A$2:$K$200;СТОЛБЕЦ();0)
 
БМВ,нет, смещаю с с 3-го в 124 данные
 
AleksSid, понял ,спасибо большое
 
БМВ, ну в моем варианте просто изменить Лист2!$A:$E на нужный  или совсем на =Лист2!$1:$1048576
 
БМВ,понял спасибо огромное за помощь
Страницы: 1
Читают тему (гостей: 1)
Наверх