Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Последний день месяца ФОРМУЛА
 
Добрый день, подскажите пожалуйста формулу.
Мне нужно получить от формулы последний день месяца от даты выплаты, если этот день выпадает на выходной, то следующий рабочий.
Пример
Дата             Результат
28.02.18       28.02.2018
30.03.18        02.04.2018
28.04.18        03.05.2018
31.05.18        31.05.2018
29.06.18        02.07.2018
31.07.18        31.07.2018
 
Добрый день!
Код
=ЕСЛИ(ДЕНЬНЕД(КОНМЕСЯЦА(ячейка_с_датой;0);2)>5;КОНМЕСЯЦА(ячейка_с_датой;0)+2;КОНМЕСЯЦА(ячейка_с_датой;0))
Изменено: GRIM - 14 Сен 2018 06:32:33
 
К сожалению не подошло(((
для июля 31.07.18        31.07.2018


Прикрепила файл
Изменено: rotex42 - 14 Сен 2018 06:43:27
 
Так 31.07.18 это рабочий день. Вторник. Что не так?
 
Извините все так, это я запуталась,


А как отразить в формуле следующий рабочий день за днем выплаты, если выпадает на выходной, то следующий рабочий.

Спасибо
 
хотя попробовала поставить дату 14.09.2018, показал 02.10.2018(вт), хотя должна быть дата 01.10.2018 (пн)
 
Дополнил формулу:
Код
=ЕСЛИ((ДЕНЬНЕД(КОНМЕСЯЦА(яч_с_дат;0);2)>5)*(ДЕНЬНЕД(КОНМЕСЯЦА(яч_с_дат;0);2)=7);КОНМЕСЯЦА(яч_с_дат;0)+1;ЕСЛИ(ДЕНЬНЕД(КОНМЕСЯЦА(яч_с_дат;0);2)>5;КОНМЕСЯЦА(яч_с_дат;0)+2;КОНМЕСЯЦА(яч_с_дат;0)))
Изменено: GRIM - 14 Сен 2018 07:23:23
 
Цитата
rotex42 написал:
А как отразить в формуле следующий рабочий день за днем выплаты, если выпадает на выходной, то следующий рабочий.
А вот здесь не совсем понятно...
Ещё +1 день от даты которую уже вычислили формулой?
 
выплата заработной платы производится в последний рабочий день месяца
июнь 29.06
июль 31.07
август 31.08
сентябрь 28.09

Перечисление НДФЛ с выплаченных сумм заработной платы, происходит на следующий рабочий день, т.е.
июнь 02.07
июль 01.08
август 03.09
сентябрь 01.10

как это отразить в формуле?


подошла формула =РАБДЕНЬ(ячейка;1;)
Изменено: rotex42 - 14 Сен 2018 08:19:30
 
Ну это совсем другой вопрос...
Т.е. нужно вычислить последний раб. день месяца, отталкиваясь от самого месяца и потом уже от него следующий рабочий.
см. пример:
 
У вас пятница то же выходной? Вариант, пятница считается рабочим.
=РАБДЕНЬ(A3-1;1)
 
AleksSid, если Вы задаете вопрос ко мне то у меня пятница также рабочий день.
К примеру март:
ДатаВаш результат
Ср 28.02.201828.02.2018
Пт 30.03.201802.04.2018
30.03.18 - это как говорит rotex42, день выдачи зарплаты(рабочий день), а на следующий день платятся налоги. Но 31.03.18 это уже суббота.
Поэтому и 02.04.18(понедельник)
 
rotex42, Рабочий день, ведь включая переносы наверно? Хотя в данном случае не попадает.

=MIN(IF(NETWORKDAYS(A1;A1+{1;2;3;4;5;6;7};$G$1:$G$8)=2;A1+{1;2;3;4;5;6;7}))
Изменено: БМВ - 14 Сен 2018 12:39:49
Страницы: 1
Читают тему (гостей: 1)
Наверх