Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммированние сумм по двум условиям
 
Добрый день.
Подскажите формулу для суммирования выплат.
Условия: суммируются суммы отпускных за определенный месяц
Отдельно за июнь, июль, август
 
=СУММЕСЛИМН(...)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
или такая сцепка :)
=суммпроизв((диапазон1=условие1)*(диапазон2=условие2)...*диапазон сумируемых)
Изменено: V - 14 Сен 2018 13:43:20
 
попробовала, но увы.... что-то делаю не так
что не так с формулой и как прописать условие что именно "июнь 2018", а не 22.06.2018
Изменено: rotex42 - 14 Сен 2018 13:51:48
 
Вы файл-то положите? или так и будем картинки смотреть?
А в формуле скобки неверно
Скажи мне, кудесник, любимец ба’гов...

 
Извините вот файл
 
Так нужно?
=СУММЕСЛИМН(H:H;B:B;"Отпуск";A:A;">"&КОНМЕСЯЦА(AC1;-1);A:A;"<="&КОНМЕСЯЦА(AC1;0))
Скажи мне, кудесник, любимец ба’гов...

 
это?
Код
=СУММПРОИЗВ((A3:A9>=AC1)*(A3:A9<=КОНМЕСЯЦА(AC1;0))*(B3:B9=AD1)*I3:I9)

в АС1 дата 01.06.2018
 
Спасибо огромное!
Все получилось!
 
Ой, с июнем все отлично получилось, а вот июль не считает(((  
12.jpg (205.08 КБ)
Изменено: rotex42 - 14 Сен 2018 14:58:41
 
Цитата
V написал:
=СУММПРОИЗВ((A3:A9>=AC1)*(A3:A9<=КОНМЕСЯЦА(AC1;0))*(B3:B9=AD1)*I3:I9)
эта формула тоже считает только июнь
33.jpg (222.12 КБ)
 
rotex42, может хватит картинками?
 
у вас текст а не даты с 6 строчки
выделите ячейки А6-А9 вкладка "Данные" - "Текст по столбцам" на последнем шаге "Формат данных столбца" выберете "дата". Готово.
Изменено: V - 14 Сен 2018 15:07:20
 
выделила, поменяла на даты.
Результат такой же
 
Цитата
rotex42 написал:
Результат такой же
значит что то сделали не так.
вот посмотрите
Изменено: V - 14 Сен 2018 15:22:43
 
Цитата
V написал:
V
Спасибо Вам огромное, ваша формула помогла. Не знаю что сделала, но все заработало))
Изменено: rotex42 - 14 Сен 2018 18:33:31
Страницы: 1
Читают тему (гостей: 1)
Наверх