Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как из текста ячейки получить все, находящееся после определенного слова, например "ProsKit"
 
Набор инструментов ProsKit PK-2623B для электроники
Отвертка диэлектрическая шлицевая ProsKit SD-800-S6.5

Есть перечень компонентов в Excel из которого надо извлечь название после слова, в данном случае ProsKit. А потом удалить это название из этой строки. Помогите а то что то запутался. Мой вариант такой = ПСТР(C109;НАЙТИ("ProsKit";C109)+8;НАЙТИ(" ";C109;(НАЙТИ("ProsKit";C109)+8)-НАЙТИ("ProsKit";C109)+8)) но что то здесь не так , ни во всех строчках срабатывает. Вот в этой выводит еще и после пробела....

Отвертка диэлектрическая торцевая ProsKit SD-800-M4.0 M4.0x125 мм    результат SD-800-M4.0 M4.0x125 мм    а надо SD-800-M4.0
Что не так подскажите.
 
название темы:
как из текста ячейки получить все, находящееся после определенного слова, например "ProsKit"

ответ:
Код
=ПРАВСИМВ(A1;ДЛСТР(A1)-7-НАЙТИ("ProsKit";A1))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Такой вариант не подходит - он извлекает все после Proskit, а нужно только одно, следующее за ним.
Нашел по Вашей наводке получилось так
=ЕСЛИОШИБКА(ПСТР(C80;НАЙТИ("ProsKit ";C80)+8;НАЙТИ(" ";ПСТР(C80;НАЙТИ("ProsKit ";C80)+8;100)));ПСТР(C80;НАЙТИ("ProsKit ";C80)+8;100))

потом удаляю
=ПОДСТАВИТЬ(C80;ЕСЛИОШИБКА(ПСТР(C80;НАЙТИ("ProsKit ";C80)+8;НАЙТИ(" ";ПСТР(C80;НАЙТИ("ProsKit ";C80)+8;100)));ПСТР(C80;НАЙТИ("ProsKit ";C80)+8;100));"")
Изменено: porydok - 17 Сен 2018 18:03:19
 
Доброе время суток
Цитата
porydok написал:
Такой вариант не подходит
Так и вопрос без файла примера тоже не подходит
 
Цитата
porydok написал: Такой вариант не подходит
И ваш вариант не отвечает требованиям пп 2.2, 2.3 Правил.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Андрей VG,  :D  
 
Оффтоп
У Вас на сайте вроде за посты баллы не дают (да и др плюшки тоже) - тогда какой смысл набивать пустые (не информативные) посты?
Спасибо - проблема решилась.
 
Цитата
porydok написал:
У Вас на сайте вроде за посты баллы не дают
Об этом Вы знаете,
Цитата
Андрей VG написал:
вопрос без файла примера тоже не подходит
А об это нет.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
вариант трёх UDF
Код
Function aaa$(t$)
 aaa = Split(Split(t, "ProsKit ")(1), " ")(0)
End Function
Код
 Function uuu$(t$)
 With CreateObject("VBScript.RegExp"): .Pattern = "ProsKit \S+"
uuu = Trim(Mid(.Execute(t)(0), 9))
 End With
End Function
Код
Function vvv$(t$)
 With CreateObject("VBScript.RegExp"): .Pattern = "ProsKit (\S+)"
  vvv = Trim(.Execute(t)(0).Submatches(0))
 End With
End Function
Изменено: кузя1972 - 17 Сен 2018 19:30:54
 
porydok, сообщения не "пустые", а говорящие о том, что нужно прикреплять файлы. Правила перечитайте, на пункт 2.3 обратите внимание.
Страницы: 1
Читают тему (гостей: 1)
Наверх