Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение двух списков и формирование таблиц с расхождениями.
 
Добрый день, Уважаемые посетители сайта.

Прошу Вашей помощи с написанием формул на схождение/расхождение списков.

По примеру:
Таблица 1 - Сравнивает сумму по № накладных (при условии, что накладные в списке 1 и списке 2 повторяются).
Таблица 2 - Выдает значения из списка 1, которых нет в списке 2.
Таблица 3 - Выдает значения из списка 2, которых нет в списке 1.

По возможности, данные таблицы должны формироваться автоматически.

Заранее благодарен!
 
доп столбец к обоим таблицам с перекрестным поиском значения типа
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A6;$D$6:$D$10;0));МАКС($C$5:C5)+1;"")
потом на основании этого столбца формируем таблицы отсутствующих и по ним собираем суммы с помощью СУММЕСЛИ
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
доп столбец к обоим таблицам с перекрестным поиском значения типа Код ? 1=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A6;$D$6:$D$10;0));МАКС($C$5:C5)+1;"")потом на основании этого столбца формируем таблицы отсутствующих и по ним собираем суммы с помощью СУММЕСЛИ
Сергей, добрый день.
Не могли бы ли Вы показать алгоритм на примере файла во вложении?
Спасибо.
 
Вариант на PQ
Каждому For свой Next
 
вот
Лень двигатель прогресса, доказано!!!
 
llt88, запомните: кнопка цитирования не для ответа!
Страницы: 1
Читают тему (гостей: 1)
Наверх