Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула для возвращения значения строки ячейки (из массива данных)
 
Здравствуйте!

Помогите, пожалуйста, есть столбец, в котором содержится нужная ячейка, её можно опознать по содержащемуся в ней номеру договора, но как получить значение строки этой ячейки?
 
_Vadim_, возможно ВПР или ИНДЕКС+ПОИСКПОЗ Вам поможет...но это не точно.. так как нет должного примера с тем что есть и что хотелось бы получить
Изменено: a.i.mershik - 17 Сен 2018 11:23:42
 
a.i.mershik, вот, прикрепил файл.
Перешли, можно сказать, на другую бух программу, раньше критерий для суммирования указывали в каждой строке, а сейчас - в одной сумма без ндс, в следующей - сумма ндс к предыдущей строке, вот, хочу написать формулу по суммированию ячейки, в которой есть нужный критерий, а также следующей по строке ячейки.
 
Номер договора нашел, а суммы нет.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
_Vadim_, ну нашли а дальше что ??это же просто текст
 
Ну, да, мне нужно найти номер строки ячейки, содержащей критерий.
 
_Vadim_, номер строки  -
Код
=ПОИСКПОЗ("*"&R[-1]C&"*";C[-3];0)
 
Формула массива:
=МИН(ЕСЛИ(ЕЧИСЛО(ПОИСК(E2;B1:B6));СТРОКА(B1:B6)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо, получилось, но открылась новая проблема, данный номер не уникален, а формула находит первое совпадение. Можно ли добавить к формуле каким-то образом поиск по критерию, чтобы она искала в в одном столбце, попутно просматривая соседний столбец, чтобы в нём содержался критерий "КОД"?
 
_Vadim_, код будет у всех разный?
Код
=ПРОСМОТР(2;1/(ПОИСК($E$2;$B$1:$B$6)*($C$1:$C$6=(ссылка_на_нужный_код));СТРОКА($B$1:$B$6))
Изменено: a.i.mershik - 17 Сен 2018 11:50:17
 
a.i.mershik, благодарю за ответ!
КОД - это вовсе не код, это сокращение для "Центр кодирования" - одно из 4 подразделений.
Ещё раз благодарю, попробую применить вашу формулу... ещё пока не понимаю принцип её работы, но оттого интересней)
 
a.i.mershik, выскакивает ошибка, ошибка в формуле... заменил в вашей формуле "ссылка_на_нужный_код" на "КОД", потом на ячейку с этим словом, всё равно ошибку выдаёт...
 
утверждение "не работает" желательно подтверждать файлом. Люди которые дают формулы в 80% проверяют её и она у них работает.
 
_Vadim_, приложите файл где вставили предложенную формулу.
 
V, как мне сохранить и после прикрепить сюда файл с формулой, на которую excel ругается?) Пока формула вызывает ошибку. Прикреплю скриншот.
! Screenshot_1.png (76.86 КБ)
 
вообщем вот
Код
=ИНДЕКС(D:D;ПОИСКПОЗ("*"&F3&"*";B:B;0))
Лень двигатель прогресса, доказано!!!
 
_Vadim_,  лишние скобки
Код
=ПРОСМОТР(2;1/(ПОИСК($F$3;$B$1:$B$7)*($C$1:$C$7="КОД"));СТРОКА($B$1:$B$7))
 
a.i.mershik, спасибо вам огромное! Странно, обычно, если лишние скобки, это легко редактируется, а сейчас он прям запорол формулу и не видит решения.
Мудрёная формула, постараюсь разобраться в ней, спасибо ещё раз!)
Страницы: 1
Читают тему (гостей: 1)
Наверх