Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проверка условия по столбцу Б по последнему и предыдущему дубликату в столбце А
 
Добрый день!
У меня есть столбец А с текстовыми данными и столбец Б с числами.
В случае, если находятся дубликаты в столбце А, то проверяются числовые значения в столбце Б самого нижнего дубликата и дубликаты и предыдущего)))
дубликаты в столбце А могут быть в хаотичном порядке, кол-во их неограничено. Как задать проверку по последнему и предыдущему дубликату по другому столбцу?
Функция Поискпоз работает по первому сверху, но мне это не подходит...; пробовал через Просмотр (2/1.....), он тоже находит самый нижний находит...не то...
Кто-нибудь сталкивался? Можете направить?
 
artemstar, пример бы посмотреть в котором исходные данные и желаемый результат видны...добрый день
 
Попробовал описать
 
artemstar, а результат какой должен бытЬ??? где он в примере7
наверное так для данного примера.
в ячейку С2 и протянуть
Код
 =ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЕСЛИ(A$2:A2;A2)=1;"";ЕСЛИ(ПРОСМОТР(2;1/(A2=A1:A$2);B1:B$2)<>"";"Нет ошибки";"ОШИБКА"));"")
Изменено: a.i.mershik - 17 Сен 2018 15:03:51
 
a.i.mershik, Спасибо....вроде работает....буду тестить....направление мыслей у меня было близкое, а конечный результат сам собрать не смог...
Страницы: 1
Читают тему (гостей: 1)
Наверх