Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Продублировать несколько раз значение на другом листе
 
Нуждаюсь в помощи!

Есть столбец со значениями, эго нужно скопировать и вставить на другую страницу, чтобы каждое значение повторялось по 4 раза!
Пример во вложении!
 
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$4;ОКРУГЛВВЕРХ(СТРОКА(A1)/4;0));"")
 
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$4;СТРОКА(4:4)/4);"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
так
 
Пишет ошибку: #NAME?
 
Решение
Код
Sub tt()
    lr = 2
    With Sheets(2)
        For i = 2 To Cells(Rows.Count, 2).End(xlUp).Row
            For j = 1 To 4
                .Cells(lr, "A") = Cells(i, 2)
                lr = lr + 1
            Next
        Next
    End With
End Sub
Изменено: skais675 - 17 Сен 2018 13:26:09
 
Всем огромное спасибо!
Все работает!!!
 
Выпонить, находясь на втором листе.
Код
Sub Macro1()
Dim LastRow As Long, i As Long, FreeRow As Long
    With Sheets("Tabelle1")
        LastRow = .Cells(Rows.Count, 2).End(xlUp).Row
        FreeRow = 2
        For i = 2 To LastRow
            Range(Cells(FreeRow, 1), Cells(FreeRow + 3, 1)) = .Cells(i, 2)
            FreeRow = FreeRow + 4
        Next
    End With
End Sub

 
Цитата
zhekachan: столбец со значениями, его нужно скопировать и вставить на другую страницу, чтобы каждое значение повторялось по 4 раза
— ИМХО гораздо лучшее название темы, чем сейчас  :sceptic:
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
Юрий М, Чуток промахнулись - у Вас по 3 записи заполняет.
Страницы: 1
Читают тему (гостей: 1)
Наверх