Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формулой проставить № круга
 
Добрый день.
Имеется таблица (А5:С17):
Фамилии участников, время выполнения (круга, рейса, задания) и порядковый номер (круга рейса, задания для каждого участника отдельный счет). Сейчас делаю пользовательской сортировкой (вначале по фамилии, потом по времени) и ставлю в ручную порядковые номера для каждого участника. Подскажите, может можно формулой проставить
 
 Может так?
 
Vik_tor, оперативно и быстро. Спасибо большое.  
 
можно немного упростить
Код
=СУММПРОИЗВ(($A$6:$A$17=A6)*($B$6:$B$17<=B6))

дополнительный вариант
Код
=СЧЁТЕСЛИМН($A$6:$A$17;A13;$B$6:$B$17;"<="&B13)
Изменено: Stics - 17 Сен 2018 13:44:46
 
Stics, Спасибо.  
 
самый короткий вариант
Код
=СЧЁТЕСЛИ($A$6:A6;A6)
 
adike, ваш вариант не учитывает расстановку по времени.
Изменено: Stics - 17 Сен 2018 14:51:08
 
Stics, если я правильно понимаю, круги и рейсы исполняются во временном пространстве, а значит второй рейс не может случиться раньше первого и таблица заполняется по мере появления данных. Временная иерархия будет соблюдена даже если таблица выгружается из системы. Но согласен, что формула перестанет работать если вручную намешать строки.
Страницы: 1
Читают тему (гостей: 1)
Наверх