Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Склейка ячеек по условию, Как склеить несколько столбцов?
 
Здравствуйте! Помогите решить задачку. Уже две недели голову ломаю над ней. Нужно склеить значения из нескольких столбцов через запятую.
Изменено: Kotiso - 17 Сен 2018 15:49:44
 
Kotiso, что то не понятно где в примере что должно получиться? может это?* https://www.planetaexcel.ru/techniques/2/81/
Изменено: a.i.mershik - 17 Сен 2018 15:59:15
 
https://www.planetaexcel.ru/techniques/7/205/
 
 Kotiso, для первых столбцов вот можно такой вариант, а для склеивания выше пример от V,
Изменено: a.i.mershik - 17 Сен 2018 16:14:01
 
Нужно произвести склейку экземпляров. Если значения идут подряд, способ 0 склейки из https://www.planetaexcel.ru/techniques/7/205/  работает, но если хотя бы одна строка не удовлетворяет условию, не работает формула так как надо.
Соответственно и длина строки тут не поможет т.к. будет два раза прописан экз. № 1.
Изменено: Kotiso - 17 Сен 2018 16:21:53
 
a.i.mershik а как прописать эти три номера из шести экземпляров  "технология" через запятую? Ячейка G5.
На работе Офис 2007.  
Изменено: Kotiso - 17 Сен 2018 16:31:07
 
Kotiso,  если есть надстройка PLEX там есть склейка по 2м условиям, но нужно будет добавить 1 столбцев вспомогательный в первой табилце так как у вас 3 условия) и вот так получиться
Снимок.JPG (63.9 КБ)
Изменено: a.i.mershik - 17 Сен 2018 16:43:21
 
a.i.mershik, скиньте  primer.xlsx с доп столбцом в чат пожалуйста
Изменено: Kotiso - 17 Сен 2018 16:51:18
 
Kotiso, а смысл? он все равно не будет у вас работать так как видимо у Вас нет данной надстройки.  ссылка на надстройку https://www.planetaexcel.ru/plex/
держите... https://www.planetaexcel.ru/plex/
Изменено: a.i.mershik - 17 Сен 2018 16:56:13
 
a.i.mershik спасибо, наглядно надо было посмотреть. Надстройка PLEX устанавливается как я понял в отдельную папку?
 
Kotiso, Вы все по ссылке узнаете если  конечно будете читать
Цитата
a.i.mershik написал:
держите...  https://www.planetaexcel.ru/plex/
 
a.i.mershik спасибо, уже архив скачал. Сейчас читаю
Изменено: Kotiso - 17 Сен 2018 17:10:35
 
a.i.mershik работает, спасибо
=ЕСЛИОШИБКА(MergeIfs(Baza!E3:E19;Baza!C3:C19;C5;Baza!H3:H19;$G$3);"")
Изменено: Kotiso - 17 Сен 2018 17:12:43
Страницы: 1
Читают тему (гостей: 1)
Наверх