Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автозаполнение ячеек с шагом
 

Добрый день!

Подскажите, как сделать, чтоб при протягивании (автозаполнении) ячеек данные подставлялись не в каждую ячейку, а с шагом через несколько ячеек, при этом данные для заполнения нужно брать из соседнего столбца В. Смотрите пример. Необходимо автозаполнение по столбцу А

 
Если шаг всегда один, как вариант:
=ЕСЛИ(ОСТАТ(СТРОКА()-1;9)=1;B2;"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
1. Вставляете формулу в первую ячейку (А2);
2. Выделяете диапазон, после которого формула должна повториться (А2-А9);
3. Протягиваете диапазон вниз (как обычно - "плюсиком" из правого нижнего угла).
Надеюсь, что я правильно понял задачу... :)
Изменено: Ренат - 17 Сен 2018 20:51:47 (изображение не вставилось первый раз...?)
Успехов. И мне того же. Благодарю. :)
 
Bema, Ренат, спасибо!
 
Код
=ЕСЛИ(ПСТР(B2;ПОИСК(".";B2)+1;1)-1=0;B2;"")
Страницы: 1
Читают тему (гостей: 1)
Наверх