Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как удалить слова паразиты из текста
 
Уважаемые гуру. Подскажите есть набор слов из нескольких ячеек в столбце S. Необходимо, после того как формула сцепит всю цепочку ячеек, удалить из этой сцепки слова паразиты. Как это сделать при помощи формулы.
 
удалите паразитов из цепочки ячеек - и они не попадут в сцепку
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Пользователь Димон, илипросто сделать формулу с проверкой каждой ячейки в S2 и протянуть
Код
=ЕСЛИ(ИЛИ(C2=$D$11;C2=$D$12;C2=$D$13);"";C2)&ЕСЛИ(ИЛИ(D2=$D$11;D2=$D$12;D2=$D$13);"";D2)&ЕСЛИ(ИЛИ(H2=$D$11;H2=$D$12;H2=$D$13);"";H2)&ЕСЛИ(ИЛИ(I2=$D$11;I2=$D$12;I2=$D$13);"";I2)&ЕСЛИ(ИЛИ(J2=$D$11;J2=$D$12;J2=$D$13);"";J2)
 
С формулой "=Если(" это понятно, однако формула выходит очень громоздкая. Хотелось бы формулой попроще. Типа =Найти() и удалить
Изменено: Пользователь Димон - 18 Сен 2018 12:16:36
 
Пользователь Димон, ну тогда просто CTRL+H найти и заменить ну или макросом, но эт не ко мне)
 
Спасибо, но этот вариант не подходит.
 
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(S3;$D$11;"");$D$12;"");$D$13;"")

Это для 3 паразитов :)
Дальше можно продолжать
Вопрос: в Вашем примере в ячейке Т6 (должно получиться): РиоДругойПивоФильтрованное - этот Другой не является паразитом или просто пропущено в примере?

ЗЫ пивка бы ща темного, чешского...

ЗЫ2 Можно сразу:
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(C:C&D:D&H:H&I:I&J:J;$D$11;"");$D$12;"");$D$13;"")
Изменено: Лузер™ - 18 Сен 2018 16:31:17
Bite my shiny metal ass!      
 
Спасибо этот вариант интереснее. Подходит.
Страницы: 1
Читают тему (гостей: 1)
Наверх