Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчёт количества занятий в одном месяце
 
В чём трудность - не пойму как сделать так, что бы эксель понимал что все ячейки где стоит одинаковая дата 01.01.2018 это занятие №1, а следующие ячейки где 02.01.2018 это занятие № 2 и т.д.
В чём задача - нужно что бы эксель выполнял вышеописанную процедуру и на выходе показывал общее количество занятий за месяц.  
 
СЧЕТЕСЛИМН, без учета фамилии - просто СЧЕТЕСЛИ
 
Цитата
vikttur написал:
СЧЕТЕСЛИМН, без учета фамилии - просто СЧЕТЕСЛИ
vikttur, простите, не очень понял. Фукнкция СЧЕТЕСЛИ  посчитает сколько ячеек например в которых дата 01.01.2018, а 02.01.2018 не посчитает. А Функции ЕСЛИМН у меня нет :(
И как быть тогда? Особенно если занятия происходят не каждый день, а количество человек не фиксировано.
Изменено: bububnik - 18 Сен 2018 13:56:31
 
bububnik,  источник https://support.office.com/ru-ru/article/%D0%9F%D0%BE%D0%B4%D1%81%D1%87%D0%B5%D1%82-%D0%BA%D0%BE%D0%...
Код
=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B10;B2:B10;0);ПОИСКПОЗ(B2:B10;B2:B10;0))>0;1))
 
так?
 
Код
=СУММ(--(СЧЁТЕСЛИ(B2:B10;СТРОКА(ИНДЕКС(B:B;МИН(B2:B10)):ИНДЕКС(B:B;МАКС(B2:B10))))>0))
формула массива
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Stics, Да, Спасибо. Скажите а есть ли возможность сделать так, что бы всё это происходило в одной ячейке? То есть всегда показывалось только максимальное число, которое и является общим количеством прошедших занятий.
 
Цитата
a.i.mershik написал:
=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B10;B2:B10;0);ПОИСКПОЗ(B2:B10;B2:B10;0))>0;1))
bububnik, а вы пробовали формулу из #4 ?
 
Сейчас попробовал, получилось. Но Возникла доп.трудность: предполагается что столбец с датами будет заполняться бесконечно, а та формула из 4 поста судя по всему работает только с диапазоном в котором есть какие то данные или как то иначе. Потому что когда я увеличиваю диапазон до, например B1000 во всей формуле, то эксель возвращает мне #н/д. Как быть?  
Изменено: bububnik - 18 Сен 2018 14:38:33
 
bububnik, перейдите по ссылке и почитайте там есть информация.
или воспользуйтесь формулой
Цитата
Ігор Гончаренко написал:
=СУММ(--(СЧЁТЕСЛИ(B2:B10;СТРОКА(ИНДЕКС(B:B;МИН(B2:B10)):ИНДЕКС(B:B;МАКС(B2:B10))))>0))
Изменено: a.i.mershik - 18 Сен 2018 14:41:29
 
Для всех ячеек подряд можно так
=СУММ(B2<>B1;C1)
Для все в одной ячейке так
=СЧЁТ(1/(ПОИСКПОЗ(B2:B99;B2:B99;)=СТРОКА(B1:B98)))
или так
=СУММ(1/СЧЁТЕСЛИ(B2:B10;B2:B10&""))
или так
=СУММ(1/СЧЁТЕСЛИ(B2:B99;B2:B99&""))-1
Скажи мне, кудесник, любимец ба’гов...

 
Спасибо всем за ответы. Похоже нужно полностью описывать всю задачу. А я рассчитывал из урезанного примера по вашим советам дальше сам уже справиться но не получилось.
Я задам вопрос по новому, с той задачей которую нужно выполнить и реальной таблицей к которой всё и должно быть применено.
Данную тему можно закрывать.  
Страницы: 1
Читают тему (гостей: 1)
Наверх