Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск в диапазоне последнего значения по указанному критерию
 
Уже сломал мозг. Вопрос к опытным товарищам.
Есть столбик с разными числами:
1
3
1,257
1,8
2,5
0,3
1,2
и т.д.
Нет ли случайно такой формулы, которая найдет последнюю по счёту (самую нижнюю) ячейку, удовлетворяющую критерию например, ">=2"
в данном случае к примеру это третий с низу столбик, число "2,5".
В идеале чтобы формула выводила номер строки, или ссылку на искомую ячейку, которую можно будет потом использовать в других формулах для обозначения диапазона.
"Поискпоз" насколько я понял, умеет что то подобное делать, если тип сопоставления -1, но вот незадача, там числа должны быть отсортированы, а у меня в разброс, да и ищет она только сверху вниз. Буду рад любым советам, даже самым идиотским :)
 
Формула массива: наибольший(если([столбик значений]>=2; строка([столбик значений]);"");1)
 
Если значения в A1:A100, то
значение:
Код
=ПРОСМОТР(2;1/($A$1:$A$100>2);$A$1:$A$100)

позиция:
Код
=ПРОСМОТР(2;1/($A$1:$A$100>2);СТРОКА($A$1:$A$100))
Изменено: ZVI - 19 Сен 2018 00:24:52
Vladimir Zakharov
Microsoft MVP – Office Apps & Services
 
Цитата
Danya-asg написал: Нет ли случайно
Случайно - нет, специально:
=ИНДЕКС(A1:A7;МАКС((A1:A7>=2)*СТРОКА(A1:A7))) (массивка)
Кусок
МАКС((A1:A7>=2)*СТРОКА(A1:A7))
выводит именно номер строки
Изменено: buchlotnik - 19 Сен 2018 00:25:19
Каждому For свой Next
 
Цитата
buchlotnik написал:
=ИНДЕКС(A1:A7;МАКС((A1:A7>=2)*СТРОКА(A1:A7))) (массивка)
Михаил, приветствую. Тут немного не корректно, если под условие не попадет ни одно значение, то макс вернет 0? а индекс весь столбец. В ячейке в результате увидим первое значение диапазона, что не корректно. Lookup и Large, при этом, хотя бы выдадут ошибку.  
Изменено: БМВ - 18 Сен 2018 22:56:03
 
Помогающие, обращайте внимание на название темы. Переименована.
Страницы: 1
Читают тему (гостей: 1)
Наверх