Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Удаление нулей, которые показывает формула
 
Добрый день.
Есть формула, которая ссылается на ячейке на другом листе:
Код
=ЕСЛИ($A2>Общий!$Q$409;"";ИНДЕКС(Общий!A$2:A$409;ПОИСКПОЗ($A2;Общий!$Q$2:$Q$408;0)))
Если на другом листе ячейка пустая - формула отображает 0.
Подскажите, пожалуйста, что необходимо к ней дописать чтобы удалить нули? И ячейки также были пустые.
Не очень хорошо разбираюсь, просьба объяснять как для чайника.
 
В настройках есть опция - отображать нулевые значения. Снимите галку.
Я сам - дурнее всякого примера! ...
 
Данная таблица будет просмотрена другими пользователями.
Не совсем удобно объяснять каждому, где нужно снимать галки.
 
helen765, если Вы снимете у себя в настройках и сохраните файл, то все кто будет просматривать Вашу таблицу, нолей не увидят.
Я сам - дурнее всякого примера! ...
 
helen765, используйте формат ячеек пользовательский и например такой "Основной;-Основной;;@"
 
чем больше вычислений - нем удобнее :)
=ЕСЛИ($A2>Общий!$Q$409;"";ЕСЛИОШИБКА(--(ИНДЕКС(Общий!A$2:A$409;ПОИСКПОЗ($A2;Общий!$Q$2:$Q$408;0))&"");""))
 
Спасибо! Формула помогла.
В некоторых ячейках диапазона есть даты. Формула показывает их как 43362.
В какое место формулы необходимо добавить ТЕКСТ? (дд.мм.гг).
Формула
=ЕСЛИ($A2>Общий!$Q$409;"";ЕСЛИОШИБКА((ИНДЕКС(Общий!A$2:A$409;ПОИСКПОЗ($A2;Общий!$Q$2:$Q$408;0))&"");""))
 
helen765, вот уже и не просто нули надо убрать. Ну не подошел просто формат, сделайте скрытие нулей через УФ. Вот только это не поможет с форматированием дат. точнее можно и это обнаружить, но только при помощи функции CELL/Ячейка, при помощи которй проверить источник, на формат даты. но формула сильно потяжелеет.
Изменено: БМВ - 20 Сен 2018 22:32:18
 
Счас придумал - чтобы не отображать 0, а заодно и ошибочные значения, можно использовать
Код
=ЕСЛИОШИБКА(1/(1/A1);"")
Вместо А1 - формула, возвращающая число.
Может кому-нибудт пригодится.
Страницы: 1
Читают тему (гостей: 1)
Наверх