Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма времени по маске
 
Здравствуйте. Подскажите пожалуйста как можно суммировать время по примеру строки 2, но с маской ввода как в строке 4 или 6?
 
fedot0v!
Обратите внимание на форматы ячеек в Вашей таблице.
 
Так как раз как то так и нужно. Ввод нужен по маске, что бы не вводить символ ":"
 
Цитата
fedotov написал:
Ввод нужен по маске, что бы не вводить символ ":"
См. ссылку:
Быстрый ввод даты и времени без разделителей
 
Мотя, спасибо за линк. А без макросов нельзя ни как?
 
=TEXT(C4;"00\:00")-TEXT(B4;"00\:00")+(C4<B4)+TEXT(E4;"00\:00")-TEXT(D4;"00\:00")+(E4<D4)+TEXT(G4;"00\:00")-TEXT(F4;"00\:00")+(G4<F4)+TEXT(I4;"00\:00")-TEXT(H4;"00\:00")+(I4<H4)
 
тёзка опередил - аналогично, только массивка
=СУММ(ЕЧЁТН(СТОЛБЕЦ(B2:H2))*(ТЕКСТ(C2:I2;"00\:00")-ТЕКСТ(B2:H2;"00\:00")+(ТЕКСТ(C2:I2;"00\:00")<ТЕКСТ(B2:H2;"00\:00"))))
а то чёрт его знает, сколько этих столбцов потом будет
Изменено: buchlotnik - 11 Окт 2018 20:47:41
Каждому For свой Next
 
Михаил, тогда совсем объединим
=SUM(ISEVEN(COLUMN(B4:H4))*(TEXT(C4:I4;"00\:00")-TEXT(B4:H4;"00\:00")+(C4:I4<B4:H4)))
 
Цитата
БМВ написал:
совсем объединим
точно - что-то я устал к концу недели  ;)
Каждому For свой Next
 
Цитата
fedotov написал:
А без макросов нельзя ни как?
А чем Вам макрос не нравится?!  :D
Спасибо Николаю Павлову!
Я бы никогда до такого макроса не додумалась!!!
Чем же лучше такие "увесистые" формулы?!
Если Вы заботитесь о простом операционисте - так он НИКОГДА в ЖИЗНИ не "состряпает" таких формул!
Но зная, что в файле все должно выполняться "на автопилоте", он никогда не оставит Вас без работы: Вы всегда будете востребованы!!!  :D  :D  :D
См. файл.
 
=TEXT(C4;"00\:00")-TEXT(B4;"00\:00")+(C4<B4)+TEXT(E4;"00\:00")-TEXT(D4;"00\:00")+(E4<D4)+TEXT(G4;"00\:00")-TEXT(F4;"00\:00")+(G4<F4)+TEXT(I4;"00\:00")-TEXT(H4;"00\:00")+(I4<H4)

БМВ, спасибо. Этот вариант работает отлично.
Цитата
Мотя написал: А чем Вам макрос не нравится?!
Много заразы через распространяют, а я параноик))) Но вообще работало
Изменено: fedotov - 11 Окт 2018 21:34:42
 
За 11 лет заразы ни разу не поймал. Может, прививку какую родители сделали? )
 
Цитата
fedotov написал:
а я параноик)))
Развеселили, однако!!!  :D  :D  :D  
 
Off
Цитата
vikttur написал:
За 11 лет заразы ни разу не поймал.
Полноценный вирус - ну почему б и нет, с учетом наработок bedvit, можно много доставить и запустить на ПК. Но я б больше опасался за просто файл вредитель, типа открыли , и почему то ваши файлы пропали …, все :-(.

fedotov,  У паранои должна быть грань.
Страницы: 1
Читают тему (гостей: 1)
Наверх