Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как сравнить время, которое больше 24 часов?, Например, как сравнить 54:32 с 48:00
 
Друзья, добрый день.
Есть ячейка, в которой записано время. Это время может быть как больше 24 часов, так и меньше (например, 4:45 и 54:32).
Нужно сравнить это время с эталоном (48 часов, 48:00) и, если время больше 48:00, то задать значение "вне срока", если меньше, тогда "ок".

Мое виденье такое: пусть А1 - ячейка, в которой указано время. Тогда в ячейке В1 должна быть формула: =IF(A1>="48:00';"вне срока";"ок").

Подскажите, пожалуйста, как правильно сравнивать время?
 
vmokuq, может так?
Код
=ЕСЛИ(A2/"48:00:00">=1;"Вне срока";"ок")
 
Или так?
=ЕСЛИ(1*A2>2;"вне времени";"ок")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
a.i.mershik,
Ваш вариант работает, спасибо и он  идеально подходит для решения задачи сравнения с любым другим заданным временем
Правда, еще хотелось бы найти встроенную функцию в Excel.

Bema,
Большое спасибо, Ваш вариант тоже подходит.
Подскажите, пожалуйста, почему 2 обозначает 2 дня? Почему в данном случае используется не цифра 48 (часов), 2880 (минут), или 0,00274 (лет)?
 
Цитата
vmokuq: почему 2 обозначает 2 дня
потому что любая дата в Excel — целое число, обозначающее количество дней с 1 января 1900 года. Время, соответственно, часть 1 дня и представляет десятичное число. Проверить это можно, выставив формат "Общий" для ячейки с датой/временем.

Основные принципы работы с датами и временем в Excel
Изменено: Jack Famous - 25 Окт 2018 10:17:46
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
Цитата
vmokuq написал:
почему 2 обозначает 2 дня?
1 это 24 часа, 2 это 48 часов. Введите в ячейку цифру 2 и примените формат [h]:mm:ss
Изменено: Bema - 25 Окт 2018 10:13:46
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх