Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Приблезительный поиск данных из одного столбца в другом.
 
Доброе время суток.

Долго гуглил, пробовал различные варианты, но в виду нехватки знаний, не смог достичь необходимого результата.
Задача следующая.
Имеется 2 таблицы:

1) 2 важных столбца
1 - ID
2 - Список карт, который покрывает ID

2) 1 столбец
1 - список имеющихся карт

Необходимо, чтобы алгоритм брал каждый номер карты из таблицы 2, сверял с каждым списком карт в таблице 1 и выводил ID в случае совпадения. В результате необходимо получить все ID на имеющиеся у нас карты.

Основная проблема с которой я столкнулся и не смог найти решения - не выходит найти номер карты в списке карт.
Например:
US3EC06M в US2EC04M,US3EC06M,US3EC07M,US3EC09M

Необязательно решать задачу за меня, можно просто указать что и где читать или искать.
Спасибо всем неравнодушным.  
Изменено: andrejshapal - 8 Ноя 2018 11:30:29
 
Доброе время суток.
Версия на Power Query.
 
в H3 и протянуть вниз
Код
=ПРОСМОТР(2;1/ПОИСК(G3;$D$3:$E$2623);$B$3:$B$2623)
Лень двигатель прогресса, доказано!!!
 
Сергей,
А реально эту формулу переделать так, чтобы значение из столбца D искалось в промежутке значений из столбца G?

Вы красиво решили мою проблему, но выяснилось, что если искать таким образом, то выводятся повторные значения, а поиск прерывается на первом найденном.

Я попробовал вот так:
Код
=ЕСЛИ(ЕНД(ПРОСМОТР(2;1/ПОИСК(D563;$G$3:$G$200);$G$3:$G$200))=ЛОЖЬ;B563;"")

Но он не находит список значений в одном значении (что логично xD)

Изменено: andrejshapal - 8 Ноя 2018 17:04:57
 
andrejshapal, я файлы не открывал, но что то мне подсказывает, что Андрей VG, решил Вашу задачу
 
Андрей VG, огромное спасибо!
Долго разбирал Power Query, но в итоге всё получилось.
Страницы: 1
Читают тему (гостей: 1)
Наверх