Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заполнение строки данными из столбца
 
Добрый день! Прошу помощи.

Требуется значения ячеек столбца одной таблицы отображать в ячейках строки другой таблицы.
Первая ячейка столбца = первой ячейке строки и т.д., соответственно.

Например, столбец

2
43
6
81
9

будет выглядеть как:

2  43  6  81  9

При изменении значений в ячейках столбца соответственно должны меняться значения в ячейках строки.

Заранее спасибо!
 
Вы собственно и ответили на свой вопрос
Цитата
Envoy написал:
Первая ячейка столбца = первой ячейке строки
 
 
Хотел вариант нарисовать, но у меня файлы Excel на сегодня закончились...
 
Envoy,
Код
 =ИНДЕКС($A:$A;СТОЛБЕЦ()-5;1)
 
Цитата
Envoy написал: Требуется
Пожалуйта - изучаем/применяем ТРАНСПОНИРОВАНИЕ формулой. Как вариант... ;)
Изменено: Z - 8 Ноя 2018 16:40:57
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
а почему
Цитата
a.i.mershik написал:
СТОЛБЕЦ()-5
 
ну, не вручную же присваивать значения каждой ячейке...
Пытаюсь через функцию СМЕЩ, но туплю, не могу в формуле задать сдвиг на одну позицию вниз по столбцу.
 
Михаил С., ну потому что я вывожу их в место которое удобно а удобно было в столбце G))))
 
Z, не подходит
пардон - не увидел "формулой"
думал простой вставкой
Изменено: Александр - 8 Ноя 2018 16:46:34
 
Александр, почему ?


Цитата
Александр написал:
не подходит
у меня происходит автозамена значения при использовании трансп()
 
Envoy, приложите ваш файл с примером - и моментально получите решение!
Вот лично мне лень придумывать, где находится ваш столбец и где строка.
 
Цитата
Александр написал: не подходит
Проверяли? Можете доказать?
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
Z написал:
Проверяли? Можете доказать?
уже извинился за невнимательность :)
Изменено: Александр - 8 Ноя 2018 16:54:08
 
a.i.mershik, тогда, независимо от столбца, с которого начинаете,
=ИНДЕКС($A:$A;СТОЛБЕЦ(A1))
 
OFF Александр, не в обиде - просто сайт не извещает, что есть новые сообщения пока я скрин мастерил... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Спасибо вам, добрые знающие люди!
Изучил транспонирование формулой.
И нюанс через ИНДЕКС для себя отметил.
 
Цитата
a.i.mershik написал:
СТОЛБЕЦ()-5
Цитата
a.i.mershik написал:
место которое удобно ...было в столбце G))))
Какой Вы коварный ;)  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema,
Цитата
Bema написал:
Какой Вы коварный  
ну просто файл-пример просить устал)
 
Цитата
Envoy написал:
ну, не вручную же присваивать значения каждой ячейке
Я так понимаю, ячеек много. Если задача "одноразовая", то можно и вручную, только не каждой ячейкой:
1. Копируем ячейки в столбце
2. Делаем специальную вставку "Вставить связь"
3. Не снимая выделение делаем замену "=" на, например, "%". Получим что-то вроде
%A1
%A2
%A3
%A4
%A5
%A6
4. Копируем и делаем специальную вставку с транспонированием в нужное место, получаем:
%A1%A2%A3%A4%A5%A6
5. Делаем замену "%" обратно на "="
Теперь есть строка, в которой находятся формулы-ссылки на ячейки столбца.
6. Ну и очищаем ячейки, заполненные на шаге 2
Страницы: 1
Читают тему (гостей: 1)
Наверх