Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Удаление из текста фразы, указанной в другом столбце
 
Добрый день. Есть файл где больше 30000 позиций. Нужно из столбца наименования удалить часть текста по производителю. Допустим есть позиция в столбце A! "холодьный стол POLAIR СМ-110" и в столбце B1 производитель "POLAIR". Необходимо в столбец C1 получить "СМ-110"
 
А из
Машина посудомоечная фронтальная GS50+DD+DP | Dihr
что получаем? и по какому признаку?
Получить в столбце "Модель"?
Формулами, макросом?
Изменено: Михаил С. - 9 Ноя 2018 10:24:04
 
Такую позицию пропустить желательно формулой
 
В С2
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(A2;ПОИСК(B2;A2)+ДЛСТР(B2);99));"")
и потягиваем.
 
Dem411, пример макросом
 
вариант UDF в столбце C и UDF uuu
Код
Function uuu$(t$, s$)
 uuu = Split(t, UCase(s))(1)
End Function
 
Код
Function vvv$(t$, s$)
  With CreateObject("VBScript.RegExp"): .Pattern = s & "(.+)$": .IgnoreCase = True
        If .test(t) Then vvv = .Execute(t)(0).Submatches(0)
  End With
End Function
Изменено: кузя1972 - 9 Ноя 2018 11:55:58
 
ещё вариант формулы в столбце C
Код
 = СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ($A2;ПРОПИСН(B2);ПОВТОР(" ";99));99))
Изменено: кузя1972 - 9 Ноя 2018 20:17:24
 
Цитата
ещё вариант
можно ещё десяток вариантов - хоть бы на один отзыв был :(
Страницы: 1
Читают тему (гостей: 1)
Наверх