Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ошибка при поиске тильды с помощью ПОИСКПОЗ
 
Доброе время суток.

Подскажите, пожалуйста, почему формула ПОИСКПОЗ не находит текстовое значение среди прочих, которое содержит в себе сивол "~".
Я осведомлена об использовании этого символа при поиске других символов, но неужели сам он нечитаем, и для значений, содержащих "~" необходимо сделать уточнение в формуле?
И как лучше в таком случае прописать его?
 
Доброе. А если искать 2 тильды?
=ПОИСКПОЗ("~~";A:A;0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Идиотка, ну поменяйте, пожалуйста, ник (логин) :-)
 
Bema, пробовала =) Для уточнения есть три файла:
* рабочий, где в конечном итоге будет реализован индекс+поискпоз
* вспомогательный (где сейчас редактирую базу данных и экспериментирую с поиском позиции
* файл-пример для форума (размещение фактических данных затруднительно в связи с коммерческой тайной между Заказчиком и аналитиком.

Итоговая формула должны была выглядеть следующим образом (в файле-примере реализовала, но выдаёт ошибку):
=ЕСЛИ(ЕОШИБКА(ПОИСК("~~";$D29;1))=ЛОЖЬ;
ИНДЕКС($A$29:$B$38;ПОИСКПОЗ($D29;$A$29:$A$38;0);2);
ИНДЕКС($A$29:$B$38;ПОИСКПОЗ($D29;$A$29:$A$38;1);2))

Хотелось, что бы она была одна для столбца, чтобы не путаться, поэтому разграничила две ситуации через ЕСЛИ.

Так вот. В вспомогательном файле часть ПОИСК("~~";$D29;1) выдаёт верный результат, а в примере и рабочем - нет.
 
Юрий М,  :( , замечательный логин! =)
 
Задвоение сообщения (не знаю, что происходит), при ответе выкидывает на прогружаемый белый экран, который не прогружается =)
Изменено: Идиотка - 12 Ноя 2018 13:06:29
 
=INDEX($A$3:$B$12;MATCH(SUBSTITUTE($D8;"~";"~~");$A$3:$A$12;0);2)

ПОИСК("*~~*";......;0)
Изменено: БМВ - 12 Ноя 2018 13:28:37
По вопросам из тем форума, личку не читаю.
 
Вот так работает:
=ИНДЕКС($A$3:$B$12;ПОИСКПОЗ(ПОДСТАВИТЬ($D3;"~";"~~");$A$3:$A$12;0);2)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Для "изначальной ситуации" в E3:
=ИНДЕКС($A$3:$B$12;ПОИСКПОЗ(ПОДСТАВИТЬ($D3;"~";"~~");$A$3:$A$12;0);2)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
БМВ, Bema, JayBhagavan, благодарю, господа =)
Изменено: Идиотка - 12 Ноя 2018 13:48:25
Страницы: 1
Читают тему (гостей: 1)
Наверх